HDU 2020 绝对值排序

时间:2023-03-09 20:15:48
HDU 2020 绝对值排序

http://acm.hdu.edu.cn/showproblem.php?pid=2020

Problem Description
输入n(n<=100)个整数,按照绝对值从大到小排序后输出。题目保证对于每一个测试实例,所有的数的绝对值都不相等。
Input
输入数据有多组,每组占一行,每行的第一个数字为n,接着是n个整数,n=0表示输入数据的结束,不做处理。 
Output
对于每个测试实例,输出排序后的结果,两个数之间用一个空格隔开。每个测试实例占一行。
Sample Input
3 3 -4 2
4 0 1 2 -3
Sample Output
-4 3 2
-3 2 1 0
代码:
#include <bits/stdc++.h>

using namespace std;

int a[111];

bool cmpabs(int x,int y)
{
return abs(x)>abs(y);
} int main()
{
int n,falg=0;
while(~scanf("%d",&n))
{
if(n==0)
break;
else
{
for(int i=1; i<=n; i++)
{
scanf("%d",&a[i]);
}
sort(a+1,a+1+n,cmpabs);
for(int i=1; i<=n; i++)
{
if(i!=n)
printf("%d ",a[i]);
else
printf("%d\n",a[i]);
}
}
}
return 0;
}