POJ2309BST(树状数组)

时间:2023-03-10 02:49:19
POJ2309BST(树状数组)
BST
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9182   Accepted: 5613

Description

Consider an infinite full binary search tree (see the figure below), the numbers in the nodes are 1, 2, 3, .... In a subtree whose root node is X, we can get the minimum number in this subtree by repeating going down the left node until the last level, and we can also find the maximum number by going down the right node. Now you are given some queries as "What are the minimum and maximum numbers in the subtree whose root node is X?" Please try to find answers for there queries. 
POJ2309BST(树状数组)

Input

In the input, the first line contains an integer N, which represents the number of queries. In the next N lines, each contains a number representing a subtree with root number X (1 <= X <= 231 - 1).

Output

There are N lines in total, the i-th of which contains the answer for the i-th query.

Sample Input

2
8
10

Sample Output

1 15
9 11

Source

强大的lowbit,树状数组太神奇了

 #include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
int lowbit(int k)
{
return k & (-k);
}
int main()
{
int t,x;
scanf("%d", &t);
while(t--)
{
scanf("%d", &x);
printf("%d %d\n",x - lowbit(x) + , x + lowbit(x) - );
}
return ;
}