【巧妙的模拟】【UVA 10881】 - Piotr's Ants/Piotr的蚂蚁

时间:2022-09-07 12:45:12
</pre></center><center style="font-family: Simsun;font-size:14px;"><span style="font-size:32px;"><strong>Problem D</strong></span><span style="font-size:24px;"><strong>Piotr's Ants</strong></span><span style="font-size:18px;">Time Limit: 2 seconds</span></center><p style="font-family: Simsun;font-size:14px;"></p><table border="0"><tbody><tr><td><small><em>"One thing is for certain: there is no stopping them;the ants will soon be here. And I, for one, welcome ournew insect overlords."</em></small></td></tr></tbody></table><p align="right" style="font-family: Simsun;font-size:14px;"><tt>Kent Brockman</tt></p><p class="paragraph" style="font-family: Simsun;font-size:14px;">Piotr likes playing with ants. He has <strong>n</strong> of them on a horizontal pole <strong>L</strong> cm long. Each ant is facing either left or right and walks at a constant speed of 1 cm/s. When two ants bump into each other, they both turn around (instantaneously) and start walking in opposite directions. Piotr knows where each of the ants starts and which direction it is facing and wants to calculate where the ants will end up <strong>T</strong> seconds from now.</p><p class="paragraph" style="font-family: Simsun;font-size:14px;"><span style="font-size:24px;"><strong>Input</strong></span>The first line of input gives the number of cases, <strong>N</strong>. <strong>N</strong> test cases follow. Each one starts with a line containing 3 integers: <strong>L</strong> , <strong>T</strong> and <strong>n</strong> <nobr>(0 <= <strong>n</strong> <= 10000)</nobr>. The next <strong>n</strong> lines give the locations of the <strong>n</strong> ants (measured in cm from the left end of the pole) and the direction they are facing (L or R).</p><p class="paragraph" style="font-family: Simsun;font-size:14px;"><span style="font-size:24px;"><strong>Output</strong></span>For each test case, output one line containing "Case #<strong>x</strong>:" followed by <strong>n</strong> lines describing the locations and directions of the <strong>n</strong> ants in the same format and order as in the input. If two or more ants are at the same location, print "Turning" instead of "L" or "R" for their direction. If an ant falls off the pole <em>before</em> <strong>T</strong>seconds, print "Fell off" for that ant. Print an empty line after each test case.</p><table width="100%" cellspacing="0" bordercolor="black" border="1" cellpadding="5" style="font-family: Simsun;"><tbody><tr valign="TOP"><td><span style="font-size:24px;"><strong>Sample Input</strong></span></td><td><span style="font-size:24px;"><strong>Sample Output</strong></span></td></tr><tr bgcolor="#D0D0D0" valign="TOP"><td><pre>2
10 1 4
1 R
5 R
3 L
10 R
10 2 3
4 R
5 L
8 R
Case #1:
2 Turning
6 R
2 Turning
Fell off Case #2:
3 L
6 R
10 R

题目大意:

一根长度为L厘米的木棍上有n只蚂蚁,每只蚂蚁要么朝左爬,要么朝右爬,速度为1厘米/秒。当两只蚂蚁相撞时,二者同时掉头(掉头时间忽略不计)。给出每只蚂蚁的初始位置和朝向,计算T秒之后每只蚂蚁的位置。

(n<=10000)

思路:

如果不思考的去模拟的话,,显然要在10000的数据面前跪

要发现到二个性质:

1.如果两个蚂蚁相撞可以看做擦肩而过。

2.蚂蚁从左端开始的排列顺序永远不变。

这样就可以根据性质一直接算出所有蚂蚁最终状态(但不知道那个蚂蚁的编号)

再根据性质二推算出每个蚂蚁应该在的位置(即知道蚂蚁是哪只初始状态的)

一道很巧妙的模拟

很可耻的看了题解,浪费的一道好题

#include<cstdio>
#include<cstdlib>
using namespace std;
typedef struct node
{
int pos;
char direct;
int rank;
}node;
node ant[10100];
int RANK[10100];
int cmp(const void *i,const void *j)
{
node *ii=(node *)i,*jj=(node *)j;
return ii->pos-jj->pos;
}
int main()
{
freopen("a.in","r",stdin);
freopen("a.out","w",stdout);
int K,KK;
int L,T,n;
while(scanf("%d",&K)!=EOF)
{
KK=K;
while(K--)
{
scanf("%d%d%d",&L,&T,&n);
for(int i=1;i<=n;i++)
{
scanf("%d %c",&ant[i].pos,&ant[i].direct);
ant[i].rank=i;
}
qsort(ant+1,n,sizeof(ant[1]),cmp);
for(int i=1;i<=n;i++)
{
RANK[ant[i].rank]=i;
if(ant[i].direct=='R')
ant[i].pos+=T;
else ant[i].pos-=T;
}
qsort(ant+1,n,sizeof(ant[1]),cmp);
for(int i=1;i<=n;i++)
if(ant[i].pos==ant[i-1].pos) ant[i-1].direct=ant[i].direct='T';
printf("Case #%d:\n",KK-K);
for(int i=1;i<=n;i++)
{
if(ant[RANK[i]].pos>=0&&ant[RANK[i]].pos<=L)
if(ant[RANK[i]].direct=='T')
printf("%d Turning\n",ant[RANK[i]].pos);
else
printf("%d %c\n",ant[RANK[i]].pos,ant[RANK[i]].direct);
else printf("Fell off\n");
}
printf("\n");
}
}
return 0;
}

【巧妙的模拟】【UVA 10881】 - Piotr's Ants/Piotr的蚂蚁的更多相关文章

  1. POJ 1852 Ants &vert;&vert; UVA 10881 - Piotr&&num;39&semi;s Ants 经典的蚂蚁问题

    两题很有趣挺经典的蚂蚁问题. 1.n只蚂蚁以1cm/s的速度在长为L的竿上爬行,当蚂蚁爬到竿子的端点就会掉落.当两只蚂蚁相撞时,只能各自反向爬回去.对于每只蚂蚁,给出距离左端的距离xi,但不知道它的朝 ...

  2. &lbrack;ACM&lowbar;模拟&rsqb; UVA 10881 Piotr&&num;39&semi;s Ants&lbrack;蚂蚁移动 数组映射 排序技巧&rsqb;

    "One thing is for certain: there is no stopping them;the ants will soon be here. And I, for one ...

  3. UVA&period;10881 Piotr's Ants &lpar;思维题&rpar;

    UVA.10881 Piotr's Ants (思维题) 题意分析 有一根长度为L cm的木棍,上有n只蚂蚁,蚂蚁要么向左爬,要么向右,速度均为1cm/s,若2只蚂蚁相撞,则蚂蚁同时调头.求解第T秒时 ...

  4. 【UVa 10881】Piotr&&num;39&semi;s Ants

    Piotr's Ants Porsition:Uva 10881 白书P9 中文改编题:[T^T][FJUT]第二届新生赛真S题地震了 "One thing is for certain: ...

  5. 思维题 UVA 10881 Piotr&&num;39&semi;s Ants

    题目传送门 /* 题意:在坐标轴上一群蚂蚁向左或向右爬,问经过ts后,蚂蚁的位置和状态 思维题:本题的关键1:蚂蚁相撞看作是对穿过去,那么只要判断谁是谁就可以了 关键2:蚂蚁的相对位置不变 关键3:o ...

  6. cogs 1456&period; &lbrack;UVa 10881&comma;Piotr&&num;39&semi;s Ants&rsqb;蚂蚁

    1456. [UVa 10881,Piotr's Ants]蚂蚁 ★   输入文件:Ants.in   输出文件:Ants.out   简单对比时间限制:1 s   内存限制:128 MB [题目描述 ...

  7. UVA 10881 Piotr&&num;39&semi;s Ants(等效变换 sort结构体排序)

    Piotr's AntsTime Limit: 2 seconds Piotr likes playing with ants. He has n of them on a horizontal po ...

  8. 10881 - Piotr&&num;39&semi;s Ants&lpar;排序)

    题目链接:10881 - Piotr's Ants 题目大意:在一个长为L的木棒上有n只蚂蚁,给出蚂蚁的初始位置以及方向,问说移动T秒后各个蚂蚁的位置以及状态,如果两只蚂蚁在移动的过程中相撞,则会同时 ...

  9. 10881 - Piotr&&num;39&semi;s Ants

    Problem D Piotr's Ants Time Limit: 2 seconds "One thing is for certain: there is no stopping th ...

随机推荐

  1. Bash 小知识点

    变量定义的时候=两边不能有空格,例如: a='Hello World' 如果变量和其它字符相连,可以用{}把变量引起来,这样就可以和相连的字符隔离 除了在变量赋值和在FOR循环语句头中,BASH中的变 ...

  2. linux ulimit的使用,如何产生core文件,调试段错误

    ---恢复内容开始--- 下面先简单介绍下ulimit命令: 1. limit -a 可以查看系统各种资源的限制,如: core文件大小,数据段的大小等. $ ulimit -a core file ...

  3. let区别(关于racket和r5rs&rpar;

    R5RS is the Revised5 Report on the Algorithmic Language Scheme.参考http://www.schemers.org/Documents/S ...

  4. Java Web - HTML 常用标签

    1.HTML head, title, body 标签 其中 meta 中的keywords是为了快速的让搜索引擎找到 <html> <head> <title>这 ...

  5. 机器学习相关的tutorial

    1. MRF 马尔可夫随机场 http://homepages.inf.ed.ac.uk/rbf/CVonline/LOCAL_COPIES/AV0809/ORCHARD/ 从MRF,讲到Gibbs分 ...

  6. FFmpeg与VS2010

    编译FFmpeg是一件痛苦的事情,一般都直接使用Zeranoe FFmpeg Builds. 如果使用这个版本,需要注意ffmpeg的帮助里的一段话: To create import librari ...

  7. Generative Adversarial Nets&lbrack;CycleGAN&rsqb;

    本文来自<Unpaired Image-to-Image Translation using Cycle-Consistent Adversarial Networks>,时间线为2017 ...

  8. Kettle实现数据抽取、转换、装入和加载数据-数据转移ETL工具

    原文地址:http://www.xue51.com/soft/5341.html Kettle是来自国外的一款开源的ETL工具,纯java编写,可以在Window.Linux.Unix上运行,绿色无需 ...

  9. Eclipse 护眼背景色设置

    链接地址:http://blog.chinaunix.net/uid-27183448-id-3509010.html 背景颜色推荐:色调:85,饱和度:123,亮度:205  文档都不再是刺眼的白底 ...

  10. Oracle事务与锁

    Oracle事务与锁 2017-12-13 目录 1 数据库事务概括  1.1 事务定义  1.2 事务生命周期  1.3 事物的特性  1.4 死锁2 事务相关语句  2.1 事务相关语句概括  2 ...