poj3928 Ping pong 树状数组

时间:2021-10-10 14:08:16

http://poj.org/problem?id=3928

Ping pong
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 2087   Accepted: 798

Description

N(3<=N<=20000) ping pong players live along a west-east street(consider the street as a line segment). Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If two players want to compete, they must choose a referee
among other ping pong players and hold the game in the referee's house. For some reason, the contestants can't choose a referee whose skill rank is higher or lower than both of theirs. The contestants have to walk to the referee's house, and because they are
lazy, they want to make their total walking distance no more than the distance between their houses. Of course all players live in different houses and the position of their houses are all different. If the referee or any of the two contestants is different,
we call two games different. Now is the problem: how many different games can be held in this ping pong street?

Input

The first line of the input contains an integer T(1<=T<=20), indicating the number of test cases, followed by T lines each of which describes a test case. 

Every test case consists of N + 1 integers. The first integer is N, the number of players. Then N distinct integers a1, a2 ... aN follow, indicating the skill rank of each player, in the order of west to east. (1 <= ai <= 100000, i = 1 ... N).

Output

For each test case, output a single line contains an integer, the total number of different games. 

Sample Input

1
3 1 2 3

Sample Output

1

Source


题意:每一个人有个能力值,两两即可比赛必须有个裁判,裁判能力值必须在两个人之间位置也必须在两个人之间,问不同的比赛安排有多少种。
简单题解:题里面有句,Now is the problem,脱口而出挖掘机技术哪家强233.。。。
想到枚举裁判即可了,求下每一个人作为裁判的方案有多少种,就是求前面有多少个比它大(小),后面有多少个比它大(小)即可。和求逆序数一样树状数组随便搞搞即可。。。。
代码:
/**
* @author neko01
*/
//#pragma comment(linker, "/STACK:102400000,102400000")
#include <cstdio>
#include <cstring>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <queue>
#include <vector>
#include <cmath>
#include <set>
#include <map>
using namespace std;
typedef long long LL;
#define min3(a,b,c) min(a,min(b,c))
#define max3(a,b,c) max(a,max(b,c))
#define pb push_back
#define mp(a,b) make_pair(a,b)
#define clr(a) memset(a,0,sizeof a)
#define clr1(a) memset(a,-1,sizeof a)
#define dbg(a) printf("%d\n",a)
typedef pair<int,int> pp;
const double eps=1e-9;
const double pi=acos(-1.0);
const int INF=0x3f3f3f3f;
const LL inf=(((LL)1)<<61)+5;
const int N=20005;
const int M=100005;
int bit[M];
int f[N];
int a[N];
LL sum(int i)
{
LL s=0;
while(i>0)
{
s+=bit[i];
i-=i&-i;
}
return s;
}
void add(int i,int x)
{
while(i<=M)
{
bit[i]+=x;
i+=i&-i;
}
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int n;
clr(bit);
scanf("%d",&n);
for(int i=0;i<n;i++)
{
scanf("%d",&a[i]);
f[i]=sum(a[i]);
add(a[i],1);
}
clr(bit);
LL ans=0;
for(int i=n-1;i>=0;i--)
{
int x=sum(a[i]);
int y=n-i-1-x;
ans+=(LL)(f[i]*y);
ans+=(LL)((i-f[i])*x);
add(a[i],1);
}
printf("%lld\n",ans);
}
return 0;
}