HDU 1222 Wolf and Rabbit(欧几里得)

时间:2023-03-09 02:51:59
HDU 1222 Wolf and Rabbit(欧几里得)

Wolf and Rabbit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9485    Accepted Submission(s):
4857

Problem Description
There is a hill with n holes around. The holes are
signed from 0 to n-1.

HDU 1222 Wolf and Rabbit(欧几里得)

A rabbit must hide in one of
the holes. A wolf searches the rabbit in anticlockwise order. The first hole he
get into is the one signed with 0. Then he will get into the hole every m holes.
For example, m=2 and n=6, the wolf will get into the holes which are signed
0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will
survive. So we call these holes the safe holes.

Input
The input starts with a positive integer P which
indicates the number of test cases. Then on the following P lines,each line
consists 2 positive integer m and n(0<m,n<2147483648).
Output
For each input m n, if safe holes exist, you should
output "YES", else output "NO" in a single line.
Sample Input
2
1 2
2 2
Sample Output
NO
YES
Author
weigang Lee
Source
Recommend
Ignatius.L   |   We have carefully selected several
similar problems for you:  1207 1299 1219 2175 1995 
 #include <iostream>
#include <cstring>
using namespace std;
int gcd(int a, int b)
{
int t;
if (a < b) { t = a; a = b; b = t; }
return b == ? a : gcd(b, a%b);
}
int main()
{
int t;
int m, n;
cin >> t;
while (t--)
{
cin >> m >> n;
int d = gcd(m, n);
if (d == ) cout << "NO" << endl;
else cout << "YES" << endl;
}
return ;
}