FZU 1856 The Troop (JAVA高精度)

时间:2022-11-12 13:45:11
FZU 1856 The Troop (JAVA高精度) Problem 1856 The Troop

Accept: 72    Submit: 245
Time Limit: 1000 mSec    Memory Limit : 32768 KB

FZU 1856 The Troop (JAVA高精度) Problem Description

The
troop is advancing. The length of the queue is x meter. The commander
is at the front of the queue, riding his horse. The crier is at the end
of the queue. If something happen, the crier should talk to the
commander. Now, the crier run to the commander. Then run back. We know
the troop has advanced x meter. So what is the number of meter the crier
run. You can assume the speed of the crier is bigger than the troop.

FZU 1856 The Troop (JAVA高精度) Input

There
are multiple test case, in every case, there will be a real number x.
which means the distance the troop advances. 0 < x < 10^1000

FZU 1856 The Troop (JAVA高精度) Output

For
each test case you should print the answer. Use the print format as
below. Print a blank line after each case. Because of the Accuracy
error,
If answer >= 100000,you should just output the front five digit. Else
round to the four digits after the decimal point.

FZU 1856 The Troop (JAVA高精度) Sample Input

100
100000

FZU 1856 The Troop (JAVA高精度) Sample Output

Case 1
241.4214

Case 2
24142

思路:直接根据样例看出这是1+根号2.
收获:JAVA 对象,类, 构造函数。http://blog.csdn.net/liujun13579/article/details/8155223
import java.math.*;
import java.util.*;
public class Main { public static void main(String[] args) {
// TODO Auto-generated method stub
Scanner in = new Scanner(System.in);
BigDecimal x, cell = BigDecimal.ONE;
cell = cell.add(new BigDecimal(Math.sqrt(2.0)));
String str;
int t = ;
while(in.hasNext()) {
x = in.nextBigDecimal();
x = x.multiply(cell);
str = x.toString();
System.out.println("Case "+ t);
t++;
if(x.compareTo(BigDecimal.valueOf(100000.0)) >= )
System.out.println(str.substring(, ));
else{
x = x.divide(BigDecimal.ONE, , RoundingMode.HALF_UP);
System.out.println(x);
}
System.out.println();
} } }