[LightOJ 1265] Island of Survival

时间:2023-03-09 05:45:55
[LightOJ 1265] Island of Survival

Island of Survival

You are in a reality show, and the show is way too real that they threw into an island. Only two kinds of animals are in the island, the tigers and the deer. Though unfortunate but the truth is that, each day exactly two animals meet each other. So, the outcomes are one of the following

a)      If you and a tiger meet, the tiger will surely kill you.

b)      If a tiger and a deer meet, the tiger will eat the deer.

c)      If two deer meet, nothing happens.

d)      If you meet a deer, you may or may not kill the deer (depends on you).

e)      If two tigers meet, they will fight each other till death. So, both will be killed.

If in some day you are sure that you will not be killed, you leave the island immediately and thus win the reality show. And you can assume that two animals in each day are chosen uniformly at random from the set of living creatures in the island (including you).

Now you want to find the expected probability of you winning the game. Since in outcome (d), you can make your own decision, you want to maximize the probability.

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case starts with a line containing two integers t (0 ≤ t ≤ 1000) and d (0 ≤ d ≤ 1000) where tdenotes the number of tigers and d denotes the number of deer.

Output

For each case, print the case number and the expected probability. Errors less than 10-6 will be ignored.

Sample Input

4

0 0

1 7

2 0

0 10

Sample Output

Case 1: 1

Case 2: 0

Case 3: 0.3333333333

Case 4: 1

题目大意:孤岛上有T只老虎,D只鹿,1个人(你).每天会有两种动物相遇,其中:

1.老虎和人相遇,人必败;

2.老虎和鹿相遇,鹿必败;

3.老虎和老虎相遇,双方都得死;

4.鹿和鹿相遇,什么也不发生;

5.人和鹿相遇,人必定不败,鹿未必;

最后让你求人活下来的概率.

我们会发现这样一个事实,人的威胁就是老虎.所以,如果到最后,还有老虎没死,那么人必死.

所以如果有奇数只老虎,人必败,输出0;若没有老虎,显然人肯定能存活,输出1;

主要是关注,有2k只老虎(k>0)时,人的存活情况.显然,人存活的情况,那2k只老虎都成对死亡.

由于我们可以直接忽略鹿的存在(不影响结果),所以在第一天,选取两只动物总共的方案数为(2k+1)2k,其中,没有人的方案数为2k(2k-1),则第一天,人存活的概率为后者除以前者,也就是(2k-1)/(2k+1).

由于最多总共有k天,则第i(1<i<=k)天时,人依然存活的概率是第i-1天的概率乘以(2(k-i+1)-1)/(2(k-i+1)+1).最后输出就好了.

 #include<cstdio>
 #include<cstring>
 #include<algorithm>
 #include<cmath>
 using namespace std;
 int T,D;
 int main(){
     int Tt; scanf("%d",&Tt);
     ; Ts<=Tt; Ts++){
         scanf("%d%d",&T,&D);
         ;
         ) ans=; else
         ) ans=; else
         ; T-=) ans*=()/();
         printf("Case %d: %.10lf\n",Ts,ans);
     }
     ;
 }