poj3069 Saruman's Army

时间:2023-03-08 21:29:45
poj3069   Saruman's Army

http://poj.org/problem?id=3069

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4 这道题讲的是白巫师要带领他的军队从一个地方到另外一个地方,走直线,但是为了监控他的军队嘞,他就用一种石头放在其中一个人身上,然后这个石头有r米的监控范围,问至少需要
多少石头(大概就是这个意思,我英语也不好啊[大哭])
然后就开始想代码,我想的是,中间一个人拿石头,那就可以监控两边的人啊,所以从第一个开始,一直向后……

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
    int n,r,a[1010];
    while(scanf("%d%d",&r,&n)==2&&n!=-1&&r!=-1)
    {
        for(int i=0; i<n; i++)
            scanf("%d",&a[i]);

sort(a,a+n);
        int sum=0,i=0;
        while(i<n)
        {
            int x=a[i];
            i++;
            while(i<n && a[i]-x<=r) i++;//这个是判断距离0处有r的点,因为有个i++,所以i=过了r距离之后的第一个i
            int p=a[i-1];//所以这个就是拿着石头的人
            while(i<n && a[i]-p<=r) i++;//这个就是右边有r的距离
            sum++;
        }
        printf("%d\n",sum);
    }
    return 0;
}