pta 习题集5-17 家谱处理

时间:2023-03-09 02:23:54
pta 习题集5-17 家谱处理

人类学研究对于家族很感兴趣,于是研究人员搜集了一些家族的家谱进行研究。实验中,使用计算机处理家谱。为了实现这个目的,研究人员将家谱转换为文本文件。下面为家谱文本文件的实例:

John
Robert
Frank
Andrew
Nancy
David

家谱文本文件中,每一行包含一个人的名字。第一行中的名字是这个家族最早的祖先。家谱仅包含最早祖先的后代,而他们的丈夫或妻子不出现在家谱中。每个人的子女比父母多缩进2个空格。以上述家谱文本文件为例,John这个家族最早的祖先,他有两个子女RobertNancyRobert有两个子女FrankAndrewNancy只有一个子女David

在实验中,研究人员还收集了家庭文件,并提取了家谱中有关两个人关系的陈述语句。下面为家谱中关系的陈述语句实例:

John is the parent of Robert
Robert is a sibling of Nancy
David is a descendant of Robert

研究人员需要判断每个陈述语句是真还是假,请编写程序帮助研究人员判断。

输入格式:

输入首先给出2个正整数NN(2≤N≤1002≤N≤100)和MM(≤100≤100),其中NN为家谱中名字的数量,MM为家谱中陈述语句的数量,输入的每行不超过70个字符。

名字的字符串由不超过10个英文字母组成。在家谱中的第一行给出的名字前没有缩进空格。家谱中的其他名字至少缩进2个空格,即他们是家谱中最早祖先(第一行给出的名字)的后代,且如果家谱中一个名字前缩进kk个空格,则下一行中名字至多缩进k+2k+2个空格。

在一个家谱中同样的名字不会出现两次,且家谱中没有出现的名字不会出现在陈述语句中。每句陈述语句格式如下,其中XY为家谱中的不同名字:

X is a child of Y
X is the parent of Y
X is a sibling of Y
X is a descendant of Y
X is an ancestor of Y

输出格式:

对于测试用例中的每句陈述语句,在一行中输出True,如果陈述为真,或False,如果陈述为假。

输入样例:

6 5
John
Robert
Frank
Andrew
Nancy
David
Robert is a child of John
Robert is an ancestor of Andrew
Robert is a sibling of Nancy
Nancy is the parent of Frank
John is a descendant of Andrew

输出样例:

True
True
True
False
False

#include <iostream>
#include <string.h>
#include <string>
#include <algorithm>
#include <math.h>
#include <stdlib.h>
#include <map> using namespace std;
int n,m;
char b[105];
map<string,int> a;
int f[105];
string s;
int num[105];
int main()
{
scanf("%d%d\n",&n,&m);
int cnt=0;
memset(num,0,sizeof(num));
memset(f,0,sizeof(f));
for(int i=1;i<=n;i++)
{
gets(b);
s="";
for(int j=0;b[j]!='\0';j++)
{
if(b[j]==' ')
num[i]++;
else
s+=b[j];
}
a[s]=++cnt;
for(int k=i-1;k>=1;k--)
{
if(num[i]==num[k])
{
f[i]=f[k];
break;
} if(num[i]==(num[k]+2))
{
f[i]=k;
break;
}
}
}
string x="",y="",z="";
for(int i=1;i<=m;i++)
{
x="";y="";z="";
gets(b);
int tag=1;
for(int j=0;b[j]!='\0';j++)
{
if(b[j]==' ')
{
tag++;
continue;
}
if(tag==1)
x+=b[j];
else if(tag==6)
y+=b[j];
else if(tag==4)
{
z+=b[j];
}
}
int ans=0;
int fx=a[x];int fy=a[y];
if(z.find("c")==0)
{
if(f[fx]==fy)
ans=1;
}
else if(z.find("a")==0)
{
while(fy!=0)
{
if(fx==f[fy])
{
ans=1;
break;
}
fy=f[fy];
} }
else if(z.find("s")==0)
{
if(f[fx]==f[fy])
ans=1;
}
else if(z.find("p")==0)
{
if(f[fy]==fx)
ans=1;
}
else if(z.find("d")==0)
{
while(fx!=0)
{
if(fy==f[fx])
{
ans=1;
break;
}
fx=f[fx];
} }
if(!ans)
printf("False\n");
else
printf("True\n"); }
return 0;
}