2057 A + B Again

时间:2023-03-09 10:00:42
2057 A + B Again

A + B Again

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 15391 Accepted Submission(s): 6713

Problem Description
There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !
Input
The input contains several test cases, please process to the end of the file.

Each case consists of two hexadecimal integers A and B in a line seperated by a blank.

The length of A and B is less than 15.
Output
For each test case,print the sum of A and B in hexadecimal in one line.
Sample Input
+A -A
+1A 12
1A -9
-1A -12
1A -AA
Sample Output
0
2C
11
-2C
-90

思路:当时写的时候,想的是把16进制转化为10进制,相加后再转化为16进制,感觉比较麻烦

就查了网上的博客,才发现16进制也可以加减,就是不能输出正负好,就设置了一个字符c来
控制正负,注意printf("%x\n",sum);和printf(“%X\n",sum);在这道题上是有区别的;刚开始就把
“X"写成"x",一直提交说答案错误!!!正确代码如下
#include<stdio.h>
int main()
{
__int64 a,b,sum;
char c;
while(scanf("%I64X %I64X",&a,&b)!=EOF)
{
sum=a+b;
if(sum<0)
{
sum=-sum;
c='-';
}
else
c=0;
if(c)
putchar(c);
printf("%I64X\n",sum);
}
return 0;
}