PAT (Advanced Level) Practice 1005 Spell It Right (20 分) 凌宸1642

时间:2023-03-09 16:07:24
PAT (Advanced Level) Practice 1005 Spell It Right (20 分) 凌宸1642

PAT (Advanced Level) Practice 1005 Spell It Right (20 分) 凌宸1642

题目描述:

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

译:给出一个非负整数 N , 你的任务是计算出 N 的每位数的和,并且用英语输出和的每一位数。


Input Specification (输入说明):

Each input file contains one test case. Each case occupies one line which contains an N (≤ 10 100 ).

译:每个输入文件包含一个测试用例,每个测试用例包含一个整数 N (≤ 10 100 ) 独占一行.


Output Specification (输出说明):

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

译:对于每个测试用例,在一行中用英语输出它们的和的每一位数。连续的两个单词之间必须用空格隔开,但是行末没有多余的空格。


Sample Input (样例输入):

12345

Sample Output (样例输出):

one five

The Idea:

题目中说明 N 的范围是 不超过 10 100 的, N 的存储我们采用 string 类型,且最大数位和也只是 999 , 所以用 int 存储完全足够。

存好数位和之后,将数位和转为一个 string 字符串,然后遍历整个字符串,找到对应数字的英文单词即可。

最后亲身教训: 不要把 0 - 9 对应的英文单词写错!!!


The Codes:

#include<bits/stdc++.h>
using namespace std;
string numbers[10] = {"zero" , "one" , "two" , "three" , "four" , "five" , "six" , "seven" , "eight" , "nine" } ;
string s , res ;
int main(){
int ans = 0 ;
getline(cin , s);
for(int i = 0 ; i < s.size() ; i ++) ans += s[i] - '0' ;
res = to_string(ans) ; // 将结果 ans 转为字符串
for(int i = 0 ; i < res.size() ; i++)
cout << numbers[res[i] - '0'] << ((i == res.size() - 1)?"\n":" ") ;
return 0 ;
}