hdoj:2085

时间:2023-03-08 17:34:31

核反应堆

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15706    Accepted Submission(s): 7036


Problem Description
某核反应堆有两类事件发生:
高能质点碰击核子时,质点被吸收,放出3个高能质点和1个低能质点;
低能质点碰击核子时,质点被吸收,放出2个高能质点和1个低能质点。
假定开始的时候(0微秒)只有一个高能质点射入核反应堆,每一微秒引起一个事件发生(对于一个事件,当前存在的所有质点都会撞击核子),试确定n微秒时高能质点和低能质点的数目。

Input
输入含有一些整数n(0≤n≤33),以微秒为单位,若n为-1表示处理结束。

Output
分别输出n微秒时刻高能质点和低能质点的数量,高能质点与低能质点数量之间以逗号空格分隔。每个输出占一行。

Sample Input
5 2
-1

Sample Output
571, 209
11, 4 提示
可以使用long long int对付GNU C++,使用__int64对付VC6
#include <iostream>
#include <string>
#include <vector> using namespace std; #define limit 34 void f(long long x, long long &a, long long &b)
{
a += 3 * x;
b += x;
}
void g(long long x, long long &a, long long &b)
{
a += 2 * x;
b += x;
}
long long a[limit];
long long b[limit];
int main()
{
int n;
a[0] = 1;
b[0] = 0; for (int i = 1; i < limit; i++)
{
f(a[i - 1], a[i], b[i]);
g(b[i-1], a[i], b[i]);
}
while (true)
{
cin >> n;
if (n == -1)
break; cout << a[n] <<", "<<b[n]<< endl;
}
return 0;
}