【hdu 1060】【求N^N最低位数字】

时间:2023-03-09 00:28:45
【hdu 1060】【求N^N最低位数字】

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12229    Accepted Submission(s): 4674

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1060

Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the leftmost digit of N^N.
Sample Input
2
3
4
Sample Output
2
2
Hint

In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.

Author
Ignatius.L
Recommend
We have carefully selected several similar problems for you:  1018 1061 1573 1066 1005 
代码:
 #include<iostream>
#include<cmath>
using namespace std;
int main()
{
int sum;
while(cin>>sum)
{
while(sum--)
{
double n;
scanf("%lf",&n);
double x=n*log10(n*1.0);
_int64 y=(_int64)x;
double xy=x-y;
int temp=(int)pow(10.0,xy);
printf("%d\n",temp);
}
}
return ;
}