SDUT OJ 数据结构实验之链表三:链表的逆置

时间:2023-03-10 02:25:54
SDUT OJ 数据结构实验之链表三:链表的逆置

数据结构实验之链表三:链表的逆置

Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description

输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的数据进行逆置,并输出逆置后的单链表数据。

Input

输入多个整数,以-1作为结束标志。

Output

输出逆置后的单链表数据。

Sample Input

12 56 4 6 55 15 33 62 -1

Sample Output

62 33 15 55 6 4 56 12

Hint

不得使用数组。

相当于从头开始拆下来再逆序建立一遍;

#include <stdio.h>
#include <stdlib.h> struct node
{
int data;
struct node *next;
}; int main()
{
struct node *head, *tail, *p, *q;
head = (struct node *)malloc(sizeof(struct node));
head->next = NULL;
tail = head; int n;
while(scanf("%d",&n)&&n!=-1)
{
p = (struct node *)malloc(sizeof(struct node));
p->next = NULL;
p->data = n;
tail->next = p;
tail = p; } p = head->next;
head->next = NULL;
q = p->next;
while(p){
p->next = head->next;
head->next = p;
p = q;
if(q) q = q->next;
} p = head->next;
while(p->next){
printf("%d ",p->data);
p = p->next; } printf("%d\n",p->data);
return 0;
}