POJ 2418 简单trie树

时间:2023-03-09 16:59:01
POJ  2418 简单trie树

Hardwood Species

Time Limit: 10000MS Memory Limit: 65536K

Total Submissions: 21845 Accepted: 8551

Description

Hardwoods are the botanical group of trees that have broad leaves, produce a fruit or nut, and generally go dormant in the winter.

America’s temperate climates produce forests with hundreds of hardwood species – trees that share certain biological characteristics. Although oak, maple and cherry all are types of hardwood trees, for example, they are different species. Together, all the hardwood species represent 40 percent of the trees in the United States.

On the other hand, softwoods, or conifers, from the Latin word meaning “cone-bearing,” have needles. Widely available US softwoods include cedar, fir, hemlock, pine, redwood, spruce and cypress. In a home, the softwoods are used primarily as structural lumber such as 2x4s and 2x6s, with some limited decorative applications.

Using satellite imaging technology, the Department of Natural Resources has compiled an inventory of every tree standing on a particular day. You are to compute the total fraction of the tree population represented by each species.

Input

Input to your program consists of a list of the species of every tree observed by the satellite; one tree per line. No species name exceeds 30 characters. There are no more than 10,000 species and no more than 1,000,000 trees.

Output

Print the name of each species represented in the population, in alphabetical order, followed by the percentage of the population it represents, to 4 decimal places.

Sample Input

Red Alder

Ash

Aspen

Basswood

Ash

Beech

Yellow Birch

Ash

Cherry

Cottonwood

Ash

Cypress

Red Elm

Gum

Hackberry

White Oak

Hickory

Pecan

Hard Maple

White Oak

Soft Maple

Red Oak

Red Oak

White Oak

Poplan

Sassafras

Sycamore

Black Walnut

Willow

Sample Output

Ash 13.7931

Aspen 3.4483

Basswood 3.4483

Beech 3.4483

Black Walnut 3.4483

Cherry 3.4483

Cottonwood 3.4483

Cypress 3.4483

Gum 3.4483

Hackberry 3.4483

Hard Maple 3.4483

Hickory 3.4483

Pecan 3.4483

Poplan 3.4483

Red Alder 3.4483

Red Elm 3.4483

Red Oak 6.8966

Sassafras 3.4483

Soft Maple 3.4483

Sycamore 3.4483

White Oak 10.3448

Willow 3.4483

Yellow Birch 3.4483

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceeded.

10000ms的time limit……….

题意:每行一个字符串,统计不同的字符串出现的百分比。最后按ASCII排序输出不同字符串和出现的百分比。

思路:

1.很好理解的简单trie树(如果我这句话伤害到其他人了,我收回这句话,。,。,。)

2.简单快排(这个真真简单,30行基本就搞定了)

3.STL神器:map

4.看到Discuss里面有用BST这个神奇的东西的(表示不会)

5.一个hash

这道题有一些比较坑的地方,建议G++WA的同学们交C++!!!

我同样的程序G++WA了,C++AC 鬼知道为什么。

另外,输入要用gets()。gets()是到’\n’结束的,空格不是结束的标志,正好适用此题。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct trie
{
int num;
trie *next[256];
};
trie *root=new trie;
char ans[55];
int cnt=0;
void insert(char ch[])
{
trie *p=root,*newtrie;
for(int i=0;ch[i]!='\0';i++)
{
if(p->next[ch[i]]==NULL)
{
newtrie=new trie;
for(int j=0;j<256;j++)
{
newtrie->next[j]=NULL;
}
newtrie->num=0;
p->next[ch[i]]=newtrie;
p=newtrie;
}
else
{
p=p->next[ch[i]];
}
}
p->num++;
}
void dfs(trie *p,int t)
{
if(p->num!=0)
{
ans[t]=0;
printf("%s %.4lf\n",ans,100*p->num/(1.0*cnt));
}
for(int i=0;i<256;i++)
{
if(p->next[i]!=NULL)
{
ans[t]=i;
dfs(p->next[i],t+1);
}
}
}
int main()
{
for(int i=0;i<256;i++) root->next[i]=NULL;
root->num=0;
char s[45];
while(gets(s))
{
insert(s);
cnt++;
}
dfs(root,0);
}

POJ  2418 简单trie树