1051. Pop Sequence (25)

时间:2023-03-08 16:56:46

题目如下:

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain
1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow,
each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

题目要求判断一个长度为N的出栈序列是否可以用一个1~N的入栈序列和一个容量为M的堆栈完成。

乍一看题目似乎很难入手,但只要仔细思考一下,可以发现其中有很大的规律可循。

我们以3217564为例,一个容量为5的堆栈,因为入栈序列已经确定为1~7,按照下面的步骤思考:

我们设将要入栈的元素为push_index,要输出的元素为x:

x=3,push_index=1,还没有压到3,要输出三,必须一直压到3,然后弹出3,此时push_index=4(下一次要压入的是4),堆栈现在从底到顶分别为12。

接下来x=2,push_index=4,已经无法通过压入元素到达x,因此只有栈顶为x时才可能得到要求的输出序列,这时候判断栈顶是不是x,不是则这个序列无法实现,是则继续判断下一个x。

同样地,x=1也是这样处理,我们发现堆栈中有12,正好输出为21,因此可以正确输出321。

下面x=7,push_index=4,一直压入到x再弹出,则push_index=7,堆栈中在弹出7后为456。

下面x=5,push_index=7,这时候又要判断栈顶是不是5了,发现栈顶是6,已经不可能得到要求的输出序列。

通过这样举例,抽象如下:

①如果当前想要输出的元素x<将要入栈的元素push_index(由入栈序列得到,从1开始),则一直压入到x,然后弹出x,同时push_index指向下一个元素。

②如果当前想要输出的元素x==将要入栈的元素push_index,说明压入再弹出即可,这时候直接把push_index后移继续处理。

③如果当前想要输出的元素x>将要入栈的元素push_index,说明只能通过出栈方式得到x,看栈顶是否是x,是则弹出,继续处理;否则输出NO。

④只有③的条件始终满足,才输出YES。

代码如下:

#include <iostream>
#include <stack>
#include <vector>
#include <stdio.h> using namespace std; int main()
{
stack<int> nums;
int M,N,K;
int push_index = 1; // 压栈序列
int index = 1; // 遍历到的出栈序列位置
int x; // 要找的元素
bool right_flag = false;
cin >> M >> N >> K;
vector<int> pop_sequence(N);
for(int i = 0; i < K; i++){
for(int j = 0; j < N; j++){
cin >> pop_sequence[j];
}
push_index = 1;
index = 1;
while(!nums.empty()) nums.pop();
right_flag = true;
while(index < N){
x = pop_sequence[index - 1];
index++;
if(x < push_index){
if(!nums.empty() && nums.top() == x){
nums.pop();
}else{
right_flag = false;
break;
}
}else if(x == push_index){
push_index++;
}else{ // x < push_index,应该压入到index为止,弹出这个,再向后判断 if(push_index > N) {
right_flag = false;
break;
} for(; push_index <= x; push_index++){
nums.push(push_index);
if(nums.size() > M){
right_flag = false;
break;
}
}
nums.pop();
}
}
if(right_flag) cout << "YES" << endl;
else cout << "NO" << endl;
} return 0;
}