03-树3 Tree Traversals Again(25 point(s)) 【Tree】

时间:2023-03-09 13:29:54
03-树3 Tree Traversals Again(25 point(s)) 【Tree】

03-树3 Tree Traversals Again(25 point(s))

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6

Push 1

Push 2

Push 3

Pop

Pop

Push 4

Pop

Pop

Push 5

Push 6

Pop

Pop

Sample Output:

3 4 2 6 5 1

思路

题目给出 入栈的过程 要求求出 该树 的后序遍历结果

入栈过程 其实就是 前序遍历的结果

然后出栈过程 是中序遍历结果

所以实际上 题目的意思 就是 给出 前序遍历 和 中序遍历 求出 后序遍历

根据题给的样例

前序遍历 1 2 3 4 5 6

中序遍历 3 2 4 1 6 5

前序遍历 是 根 左 右

中序遍历 是 左 根 右

后序遍历 是 左 右 根

所以 我们可以认为 对于一棵树 来说 前序遍历的 第一个节点 就是它的根节点

然后 从 中序遍历 去找 直到 找到根节点,那么 根节点 前面的元素 就是左子树 右边的 元素 就是 右子树 然后 再去 前序遍历 找相应的元素区间 就是 对应的 左子树 区间 和 右子树 区间

其实下面的过程 就是 递归 重叠子问题的过程

AC代码

#include <cstdio>
#include <cstring>
#include <ctype.h>
#include <cstdlib>
#include <cmath>
#include <climits>
#include <ctime>
#include <iostream>
#include <algorithm>
#include <deque>
#include <vector>
#include <queue>
#include <string>
#include <map>
#include <stack>
#include <set>
#include <numeric>
#include <sstream>
#include <iomanip>
#include <limits> #define CLR(a) memset(a, 0, sizeof(a))
#define pb push_back using namespace std;
typedef long long ll;
typedef long double ld;
typedef unsigned long long ull;
typedef pair <int, int> pii;
typedef pair <ll, ll> pll;
typedef pair<string, int> psi;
typedef pair<string, string> pss; const double PI = 3.14159265358979323846264338327;
const double E = exp(1);
const double eps = 1e-30; const int INF = 0x3f3f3f3f;
const int maxn = 1e3 + 5;
const int MOD = 1e9 + 7; vector <int> pre, in, ans; void post(int root, int start, int end)
{
if (start >= end)
return;
int i = start;
while (i < end && in[i] != pre[root])
i++;
int len = i - start;
post(root + 1, start, i);
post(root + len + 1, i + 1, end);
ans.pb(pre[root]);
} void print(vector <int> v)
{
vector <int>::iterator it;
for (it = v.begin(); it != v.end(); it++)
{
if (it != v.begin())
printf(" ");
printf("%d", (*it));
}
printf("\n");
} int main()
{
stack <int> st;
int n;
scanf("%d", &n);
int m = n << 1;
string s;
int num;
for (int i = 0; i < m; i++)
{
cin >> s;
if (s == "Push")
{
scanf("%d", &num);
st.push(num);
pre.pb(num);
}
else
{
in.pb(st.top());
st.pop();
}
}
post(0, 0, n);
print(ans);
}