hdu 2112(字典树+最短路)

时间:2023-03-09 01:40:20
hdu 2112(字典树+最短路)

HDU Today

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 23388    Accepted Submission(s): 5614

Problem Description
经过锦囊相助,海东集团终于度过了危机,从此,HDU的发展就一直顺风顺水,到了2050年,集团已经相当规模了,据说进入了钱江肉丝经济开发区500强。这时候,XHD夫妇也退居了二线,并在风景秀美的诸暨市浬浦镇陶姚村买了个房子,开始安度晚年了。
这样住了一段时间,徐总对当地的交通还是不太了解。有时很郁闷,想去一个地方又不知道应该乘什么公交车,在什么地方转车,在什么地方下车(其实徐总自己有车,却一定要与民同乐,这就是徐总的性格)。
徐总经常会问蹩脚的英文问路:“Can you help me?”。看着他那迷茫而又无助的眼神,热心的你能帮帮他吗?
请帮助他用最短的时间到达目的地(假设每一路公交车都只在起点站和终点站停,而且随时都会开)。
Input
输入数据有多组,每组的第一行是公交车的总数N(0<=N<=10000);
第二行有徐总的所在地start,他的目的地end;
接着有n行,每行有站名s,站名e,以及从s到e的时间整数t(0<t<100)(每个地名是一个长度不超过30的字符串)。
note:一组数据中地名数不会超过150个。
如果N==-1,表示输入结束。
Output
如果徐总能到达目的地,输出最短的时间;否则,输出“-1”。
Sample Input
6
xiasha westlake
xiasha station 60
xiasha ShoppingCenterofHangZhou 30
station westlake 20
ShoppingCenterofHangZhou supermarket 10
xiasha supermarket 50
supermarket westlake 10
-1
Sample Output
50

Hint:
The best route is:
xiasha->ShoppingCenterofHangZhou->supermarket->westlake

本来可以1A的,漏看了输出-1,郁闷。
没什么好说的,用容器也好,字典树也好 = =
import java.util.Scanner;
class Trie{
int k =1;
private Node root;
public Trie() {
root = new Node();
}
int insert(String str){
Node t = root;
int idx;
for(int i=0;i<str.length();i++){
if(str.charAt(i)>='a'&&str.charAt(i)<='z'){
idx = str.charAt(i)-'a';
}else{
idx = str.charAt(i)-'A'+26;
}
if(t.nodes[idx]==null){
Node node = new Node();
t.nodes[idx] = node;
}
t = t.nodes[idx];
}
if(t.id==0) t.id = k++;
return t.id;
}
class Node{
Node [] nodes;
int id;
public Node() {
nodes = new Node[52];
id = 0;
}
}
} public class Main {
static int [][] map;
static boolean [] vis;
static int [] low;
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
while(sc.hasNext()){
int n = sc.nextInt();
if(n==-1) break;
map = new int[155][155];
low = new int[155];
vis = new boolean[155];
for(int i=0;i<155;i++){
for(int j=0;j<155;j++){
map[i][j] = 999999999;
}
}
Trie tree = new Trie();
String str1,str2;
str1 = sc.next();str2 = sc.next();
int start = tree.insert(str1);
int end = tree.insert(str2);
for(int i=0;i<n;i++){
str1 = sc.next();
str2 = sc.next();
int a = tree.insert(str1);
int b = tree.insert(str2);
int c = sc.nextInt();
map[a][b] = map[b][a] = c;
}
int k = tree.k;
int cost = dij(start, end, k);
if(cost>=999999999) System.out.println(-1);
else System.out.println(cost);
}
}
static int dij(int pos,int end,int n){
for(int i=0;i<n;i++){
low[i] = map[pos][i];
vis[i] = false;
}
vis[pos] = true;
low[pos] = 0;
for(int i=1;i<n;i++){
int Min = 999999999;
for(int j=0;j<n;j++){
if(Min>low[j]&&!vis[j]){
pos = j;
Min = low[j];
}
}
vis[pos] = true;
for(int j=0;j<n;j++){
if(low[j]>low[pos]+map[pos][j]&&!vis[j]){
low[j]=low[pos]+map[pos][j];
}
}
}
return low[end];
}
}