HDUOJ----1165Eddy's research II

时间:2023-03-09 19:35:55
HDUOJ----1165Eddy's research II

Eddy's research II

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2706    Accepted Submission(s): 985

Problem Description
As
is known, Ackermann function plays an important role in the sphere of
theoretical computer science. However, in the other hand, the dramatic
fast increasing pace of the function caused the value of Ackermann
function hard to calcuate.

Ackermann function can be defined recursively as follows:
HDUOJ----1165Eddy's research II

Now
Eddy Gives you two numbers: m and n, your task is to compute the value
of A(m,n) .This is so easy problem,If you slove this problem,you will
receive a prize(Eddy will invite you to hdu restaurant to have supper).

Input
Each line of the input will have two integers, namely m, n, where 0 < m < =3.
Note that when m<3, n can be any integer less than 1000000, while m=3, the value of n is restricted within 24.
Input is terminated by end of file.
Output
For each value of m,n, print out the value of A(m,n).
Sample Input
1 3
2 4
Sample Output
5
11
代码:
 /*@coder龚细军*/
#include<stdio.h>
int Ackermann(int m,int n)
{
if(m==) return n+;
else if(m==) return n+;
else if(m==) return *n+;
else if(m==) return (<<n+)-;
}
int main()
{
int n,m;
while(~scanf("%d%d",&m,&n))
{
printf("%d\n",Ackermann(m,n));
}
return ;
}