Count the Trees[HDU1131]

时间:2023-03-09 15:23:18
Count the Trees[HDU1131]

Count the Trees

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1248    Accepted Submission(s): 812

Problem Description
Another common social inability is known as ACM (Abnormally Compulsive Meditation). This psychological disorder is somewhat common among programmers. It can be described as the temporary (although frequent) loss of the faculty of speech when the whole power of the brain is applied to something extremely interesting or challenging.
Juan is a very gifted programmer, and has a severe case of ACM (he even participated in an ACM world championship a few months ago). Lately, his loved ones are worried about him, because he has found a new exciting problem to exercise his intellectual powers, and he has been speechless for several weeks now. The problem is the determination of the number of different labeled binary trees that can be built using exactly n different elements.

For example, given one element A, just one binary tree can be formed (using A as the root of the tree). With two elements, A and B, four different binary trees can be created, as shown in the figure.

If you are able to provide a solution for this problem, Juan will be able to talk again, and his friends and family will be forever grateful.

Input
The input will consist of several input cases, one per line. Each input case will be specified by the number n ( 1 ≤ n ≤ 100 ) of different elements that must be used to form the trees. A number 0 will mark the end of input and is not to be processed.

Output
For each input case print the number of binary trees that can be built using the n elements, followed by a newline character.

Sample Input
1
2
10
25
0

Sample Output
1
4
60949324800
75414671852339208296275849248768000000

Source
UVA

Recommend
Eddy

If the N nodes are the same,there are h[N] different kinds of shapes.h[N] is the n-th Catalan Number.Now the N nodes are labled from 1 to N,so frac(N) should be multiplied.

#include<iostream>
using namespace std;
#ifndef HUGEINT
#define HUGEINT
#include<string>
using namespace std;
class hugeint
{
friend istream operator>> (istream&,hugeint&);
friend ostream operator<< (ostream&,hugeint&);
public:
hugeint()
{
len=0;
memset(num,0,sizeof(num));
}
hugeint(int x)
{
int p;
memset(num,0,sizeof(num));
p=x;
len=0;
while (p>0)
{
len++;
num[len]=p%10;
p/=10;
}
}
hugeint(string s)
{
int i;
len=s.size();
for (i=1;i<=len;i++)
num[i]=int(s[len-i])-48;
}
istream& operator >> (istream& is)
{
int i;
is>>s;
len=s.size();
for (i=1;i<=len;i++)
num[i]=int(s[len-i])-48;
return is;
}
ostream& operator << (ostream& os)
{
int i;
for (i=len;i>=1;i--)
cout<<num[i];
return os;
}
void clear()
{
int i;
for (i=1;i<=len;i++)
{
num[i+1]+=num[i]/10;
num[i]%=10;
}
while ((num[len]==0)&&(len>1)) len--;
}
int compare(hugeint t)
{
int i;
(*this).clear();
t.clear();
if (len>t.len) return 1;
if (len<t.len) return -1;
for (i=len;i>=1;i--)
{
if (num[i]>t.num[i]) return 1;
if (num[i]<t.num[i]) return -1;
}
return 0;
}
hugeint operator = (hugeint t)
{
int i;
len=t.len;
for (i=1;i<=len;i++)
num[i]=t.num[i];
return *this;
}
hugeint operator + (hugeint t)
{
int i;
if (t.len>len) len=t.len;
for (i=1;i<=t.len;i++) num[i]+=t.num[i];
len++;
(*this).clear();
return *this;
}
hugeint operator - (hugeint t)
{
hugeint temp;
int i;
if ((*this).compare(t)<0)
{
temp=t;
t=(*this);
}
else temp=(*this);
for (i=1;i<=temp.len;i++)
{
temp.num[i+1]--;
temp.num[i]+=(10-t.num[i]);
}
temp.clear();
return temp;
}
hugeint operator * (hugeint t)
{
hugeint temp;
int i,j;
for (i=1;i<=(*this).len;i++)
for (j=1;j<=t.len;j++)
temp.num[i+j-1]+=(*this).num[i]*t.num[j];
temp.len=(*this).len+t.len;
temp.clear();
return temp;
}
hugeint operator / (hugeint t)
{
hugeint c=0,d=0;
int i,j,p;
c.len=(*this).len; d.len=1;
for (j=(*this).len;j>=1;j--)
{
d.len++;
for (p=d.len;p>=2;p--)
d.num[p]=d.num[p-1];
d.num[1]=(*this).num[j];
while (d.compare(t)>=0)
{
c.num[j]++;
d=d-t;
}
}
c.clear();
d.clear();
return c;
}
hugeint operator % (hugeint t)
{
hugeint c,d;
int i,j,p;
for (i=1;i<=1000;i++) c.num[i]=0;
for (i=1;i<=1000;i++) d.num[i]=0;
c.len=len; d.len=1;
for (j=len;j>=1;j--)
{
d.len++;
for (p=d.len;p>=2;p--)
d.num[p]=d.num[p-1];
d.num[1]=num[j];
while (d.compare(t)>=0)
{
c.num[j]++;
d=d-t;
}
}
c.clear();
d.clear();
return d;
}
hugeint operator ++ ()
{
(*this)=(*this)+1;
return *this;
}
hugeint operator -- ()
{
(*this)=(*this)-1;
return *this;
}
hugeint operator += (hugeint t)
{
(*this)=(*this)+t;
return *this;
}
hugeint operator -= (hugeint t)
{
(*this)=(*this)-t;
return *this;
}
hugeint operator *= (hugeint t)
{
(*this)=(*this)*t;
return *this;
}
hugeint operator /= (hugeint t)
{
(*this)=(*this)/t;
return *this;
}
hugeint operator %= (hugeint t)
{
(*this)=(*this)%t;
return *this;
}
bool operator == (hugeint t)
{
int i;
if (len!=t.len) return false;
for (i=1;i<=len;i++)
if (num[i]!=t.num[i]) return false;
return true;
}
bool operator >= (hugeint t)
{
int x;
x=(*this).compare(t);
if (x>=0) return true;
return false;
}
bool operator <= (hugeint t)
{
int x;
x=(*this).compare(t);
if (x<=0) return true;
return false;
}
bool operator > (hugeint t)
{
int x;
x=(*this).compare(t);
if (x>0) return true;
return false;
}
bool operator < (hugeint t)
{
int x;
x=(*this).compare(t);
if (x<0) return true;
return false;
}
~hugeint() {}
private:
int num[1001];
int len;
string s;
};
#endif
hugeint h[125];
hugeint frac[125];
int i,N;
int main()
{
frac[0]=1;
h[0]=1;
for (i=1;i<=100;i++) frac[i]=frac[i-1]*i;
for (i=1;i<=100;i++)
{
h[i]=h[i-1]*(4*i-2);
hugeint tmp=i+1;
h[i]=h[i]/tmp;
}
while (scanf("%d",&N)!=EOF)
{
if (N==0) return 0;
hugeint ans=frac[N]*h[N];
ans<<cout;
cout<<endl;
}
return 0;
}