YTU 2616: A代码完善--简易二元运算

时间:2023-03-09 07:32:18
YTU 2616: A代码完善--简易二元运算

2616: A代码完善--简易二元运算

时间限制: 1 Sec  内存限制: 128 MB

提交: 280  解决: 187

题目描述

注:本题只需要提交填写部分的代码,请按照C++方式提交。

编写二元运算类,实现整数的加、减、乘和除四种运算。

#include <stdio.h>

#include <iostream>

using namespace std;

class FourArithOper

{

private:

    int operand1,operand2;

    char operator1;

public:

    FourArithOper(char op,int op1,int op2)

    {

        operand1=op1;

        operand2=op2;

        operator1=op;

    }

    void Algorithm()

    {

        cout<<operand1<<operator1<<operand2<<"=";

/**************************************************   

       请在该部分补充缺少的代码

**************************************************/

        cout<<endl;

    }

};

int  main()

{

    int op1,op2;

    char op;

    cin>>op>>op1>>op2; //操作符,运算数1,运算数2

    FourArithOper fa(op,op1,op2);

    fa.Algorithm();

    return 0;

}

输入

运算符,运算数1,运算数2

输出

按照运算符计算的结果(除法运算保留整数部分)

样例输入

+ 10 20

样例输出

10+20=30

迷失在幽谷中的鸟儿,独自飞翔在这偌大的天地间,却不知自己该飞往何方……

#include <stdio.h>
#include <iostream>
using namespace std;
class FourArithOper
{
private:
int operand1,operand2;
char operator1;
public:
FourArithOper(char op,int op1,int op2)
{
operand1=op1;
operand2=op2;
operator1=op;
}
void Algorithm()
{
cout<<operand1<<operator1<<operand2<<"=";
if(operator1=='+')cout<<operand2+operand1;
if(operator1=='-')cout<<operand1-operand2;
if(operator1=='*')cout<<operand2*operand1;
if(operator1=='/')cout<<operand1/operand2;
cout<<endl;
}
};
int main()
{
int op1,op2;
char op;
cin>>op>>op1>>op2; //操作符,运算数1,运算数2
FourArithOper fa(op,op1,op2);
fa.Algorithm();
return 0;
}