POJ 1579-Function Run Fun(内存搜索)

时间:2022-01-05 08:40:31
Function Run Fun
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 16503   Accepted: 8514

Description

We all love recursion! Don't we? 



Consider a three-parameter recursive function w(a, b, c): 



if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns: 





if a > 20 or b > 20 or c > 20, then w(a, b, c) returns: 

w(20, 20, 20) 



if a < b and b < c, then w(a, b, c) returns: 

w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c) 



otherwise it returns: 

w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1) 



This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion. 

Input

The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.

Output

Print the value for w(a,b,c) for each triple.

Sample Input

1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1

Sample Output

w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1
巨水。。
一開始wa了一组数据 (0,21,21)
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <string>
#include <cctype>
#include <vector>
#include <cstdio>
#include <cmath>
#include <deque>
#include <stack>
#include <map>
#include <set>
#define ll long long
#define maxn 116
#define pp pair<int,int>
#define INF 0x3f3f3f3f
#define max(x,y) ( ((x) > (y)) ? (x) : (y) )
#define min(x,y) ( ((x) > (y)) ? (y) : (x) )
using namespace std;
int n,m,dp[22][22][22];
int dfs(int x,int y,int z)
{
if(x<=0||y<=0||z<=0)
return 1;
if(x>20||y>20||z>20)
return dfs(20,20,20);
if(dp[x][y][z]!=INF)
return dp[x][y][z];
dp[x][y][z]=0;
if(x<y&&y<z)
dp[x][y][z]+=(dfs(x,y,z-1)+dfs(x,y-1,z-1)-dfs(x,y-1,z));
else dp[x][y][z]+=(dfs(x-1,y,z)+dfs(x-1,y-1,z)+dfs(x-1,y,z-1)-dfs(x-1,y-1,z-1));
return dp[x][y][z];
}
int main()
{
int a,b,c;
while(scanf("%d%d%d",&a,&b,&c))
{
if(a==-1&&b==-1&&c==-1)break;
memset(dp,INF,sizeof(dp));
printf("w(%d, %d, %d) = %d\n",a,b,c,dfs(a,b,c));
}
return 0;
}

版权声明:本文博客原创文章。博客,未经同意,不得转载。