hdu 5398 动态树LCT

时间:2022-12-15 19:52:31

GCD Tree

Time Limit: 5000/2500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 415    Accepted Submission(s): 172

Problem Description
Teacher Mai has a graph with n vertices numbered from 1 to n. For every edge(u,v), the weight is gcd(u,v). (gcd(u,v) means the greatest common divisor of number uand v).

You need to find a subset of the edges that forms a tree that includes every vertex, where the total weight of all the edges in the tree is maximized. Print the total weight of these edges.

 
Input
There are multiple test cases(about 105).

For each test case, there is only one line contains one number n(1≤n≤105).

 
Output
For each test case, print the answer.
 
Sample Input
1
2
3
4
5
 
Sample Output
0
1
2
4
5
/*
hdu 5398 动态树LCT problem:
给你n个点,让你构成一棵树,边的权值为端点的最大公约数. 求树的最大边权和 solve:
枚举所有点,然后贪心的思想.如果n-1个点构成了一个最大的生成树,那么加入第n个点时我们应尽可能把它往
自己的约数上连(大->小).这样的话就在连接第二个约数的时候就会构成环,所以需要将 当前点-->当前约数点的链上
断开最小的一条边.
所以可以枚举 点和其约数,然后利用LCT维护链上面的最小边. 就这个想了很久,不知道应该吧边权保存在哪个端点
比较好,总感觉会有矛盾 = =||. 结果发现完全可以弄个点来替代边,将点上的值初始化无限大就行了T_T,好2... hhh-2016-08-21 16:43:04
*/
#pragma comment(linker,"/STACK:124000000,124000000")
#include <algorithm>
#include <iostream>
#include <cstdlib>
#include <cstdio>
#include <cstring>
#include <vector>
#include <map>
#define lson ch[0]
#define rson ch[1]
#define ll long long
#define clr(a,b) memset(a,b,sizeof(a))
#define key_val ch[ch[root][1]][0]
using namespace std;
const int maxn = 100100;
const int INF = 0x3f3f3f3f; struct Node* null;
struct Node
{
Node* ch[2] ;
Node* fa;
int Min;
Node* Minnode;
int Size,lpos,rpos ;
int rev;
void newnode(int v)
{
Min = v;
Size = 1 ;
Minnode = this;
lpos = rpos = 0;
fa = ch[0] = ch[1] = null ;
rev = 0;
}
void ini()
{
Min = INF;
Size = 1 ;
Minnode = this;
lpos = rpos = 0;
fa = ch[0] = ch[1] = null ;
rev = 0;
}
void update_rev()
{
if(this == null)
return ;
swap(ch[0],ch[1]);
rev ^= 1;
} void push_up ()
{
Minnode = this;
if(ch[0] && ch[0]->Minnode->Min < Minnode->Min)
Minnode = ch[0]->Minnode;
if(ch[1] && ch[1]->Minnode->Min < Minnode->Min)
Minnode = ch[1]->Minnode;
} void push_down()
{
if(rev)
{
ch[0]->update_rev();
ch[1]->update_rev();
rev = 0;
}
} void link_child ( Node* o , int d )
{
ch[d] = o ;
o->fa = this ;
} int isroot()
{
return fa == null || this != fa->ch[0] && this != fa->ch[1] ;
}
void sign_down ()
{
if ( !isroot () ) fa->sign_down () ;
push_down () ;
}
void Rotate ( int d )
{
Node* p = fa ;
Node* gp = fa->fa ;
p->link_child ( ch[d] , !d ) ;
if ( !p->isroot () )
{
if ( gp->ch[0] == p ) gp->link_child ( this , 0 ) ;
else gp->link_child ( this , 1 ) ;
}
else fa = gp ;
link_child ( p , d ) ;
p->push_up () ;
} void splay ()
{
sign_down () ;
while ( !isroot () )
{
if ( fa->isroot () )
{
this == fa->ch[0] ? Rotate ( 1 ) : Rotate ( 0 ) ;
}
else
{
if ( fa == fa->fa->ch[0] )
{
this == fa->ch[0] ? fa->Rotate ( 1 ) : Rotate ( 0 ) ;
Rotate ( 1 ) ;
}
else
{
this == fa->ch[1] ? fa->Rotate ( 0 ) : Rotate ( 1 ) ;
Rotate ( 0 ) ;
}
}
}
push_up () ;
} void access()
{
Node* o = this ;
Node* x = null ;
while ( o != null )
{
o->splay () ;
o->link_child ( x , 1 ) ;
o->push_up () ;
x = o ;
o = o->fa ;
}
splay () ;
} void make_root()
{
access();
update_rev();
} void cut()
{
access();
ch[0]->fa = null;
ch[0] = null;
push_up();
}
Node* find_root ()
{
access () ;
Node* o = this ;
while ( o->ch[0] != null )
{
o->push_down () ;
o = o->ch[0] ;
}
return o ;
}
void cut(Node* to)
{
to->make_root();
cut();
} void link(Node* to)
{
to->make_root();
to->fa = this;
}
Node* query(Node* to)
{
to->make_root();
access();
return Minnode;
}
};
Node memory_pool[maxn*2];
Node* now;
Node* node[maxn]; void Clear()
{
now = memory_pool;
now->newnode(INF);
null = now ++;
null->Size = 0;
}
int dp[maxn];
vector<int > vec[maxn]; void init()
{
Clear();
for(int i = 100000; i >= 1; i--)
{
now->newnode(INF);
node[i] = now++;
for(int j = i+i; j <= 100000; j+=i)
{
vec[j].push_back(i);
}
}
int tans = 0;
dp[1] = 0;
now->newnode(INF),node[1] = now++;
for(int i =2; i <= 100000; i++)
{
// cout << "number:" << i<<endl;
now->newnode(vec[i][0]);
Node *tp = now++;
tp->link(node[i]);
tp->link(node[vec[i][0]]);
tp->lpos = i,tp->rpos = vec[i][0];
tans += vec[i][0];
// cout << tp->lpos <<" " <<tp->rpos <<" " <<tans <<endl;
for(int j = 1;j < vec[i].size();j++)
{
int to = vec[i][j];
// cout <<"to "<<to <<endl; Node* tMin = node[to]->query(node[i]);
// cout <<"Min:" << tMin->lpos <<" " <<tMin->rpos <<" "<<tMin->Min <<endl;
if(tMin->Min < to)
{
tans -= tMin->Min;
tMin->cut(node[tMin->lpos]);
// cout <<"cut1 ";
tMin->cut(node[tMin->rpos]);
// cout << "cut2" <<endl;
tMin->ini();
tMin->Min = to,tMin->lpos = i,tMin->rpos = to;
// cout << i <<" " <<to<<endl; tMin->link(node[i]);
// cout <<"link1 ";
tMin->link(node[to]);
// cout << "link2" <<endl;
tans += to;
}
}
dp[i] = tans ;
}
} int main()
{ // freopen("in.txt","r",stdin);
init();
int n;
while( scanf("%d",&n) !=EOF)
{
printf("%d\n",dp[n]);
}
return 0;
}

  

hdu 5398 动态树LCT的更多相关文章

  1. hdu 5002 &lpar;动态树lct&rpar;

    Tree Time Limit: 16000/8000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)Total Submi ...

  2. hdu 5314 动态树

    Happy King Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)Tot ...

  3. HDU 4718 The LCIS on the Tree (动态树LCT)

    The LCIS on the Tree Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Oth ...

  4. 动态树LCT小结

    最开始看动态树不知道找了多少资料,总感觉不能完全理解.但其实理解了就是那么一回事...动态树在某种意思上来说跟树链剖分很相似,都是为了解决序列问题,树链剖分由于树的形态是不变的,所以可以通过预处理节点 ...

  5. bzoj2049-洞穴勘测&lpar;动态树lct模板题&rpar;

    Description 辉辉热衷于洞穴勘测.某天,他按照地图来到了一片被标记为JSZX的洞穴群地区.经过初步勘测,辉辉发现这片区域由n个洞穴(分别编号为1到n)以及若干通道组成,并且每条通道连接了恰好 ...

  6. &lbrack;模板&rsqb; 动态树&sol;LCT

    简介 LCT是一种数据结构, 可以维护树的动态加边, 删边, 维护链上信息(满足结合律), 单次操作时间复杂度 \(O(\log n)\).(不会证) 思想类似树链剖分, 因为splay可以换根, 用 ...

  7. 动态树LCT&lpar;Link-cut-tree&rpar;总结&plus;模板题&plus;各种题目

    一.理解LCT的工作原理 先看一道例题: 让你维护一棵给定的树,需要支持下面两种操作: Change x val:  令x点的点权变为val Query x y:  计算x,y之间的唯一的最短路径的点 ...

  8. SPOJ OTOCI 动态树 LCT

    SPOJ OTOCI 裸的动态树问题. 回顾一下我们对树的认识. 最初,它是一个连通的无向的无环的图,然后我们发现由一个根出发进行BFS 会出现层次分明的树状图形. 然后根据树的递归和层次性质,我们得 ...

  9. BZOJ 2002&colon; &lbrack;Hnoi2010&rsqb;Bounce 弹飞绵羊 (动态树LCT)

    2002: [Hnoi2010]Bounce 弹飞绵羊 Time Limit: 10 Sec  Memory Limit: 259 MBSubmit: 2843  Solved: 1519[Submi ...

随机推荐

  1. Replication的犄角旮旯(四)--关于事务复制的监控

    <Replication的犄角旮旯>系列导读 Replication的犄角旮旯(一)--变更订阅端表名的应用场景 Replication的犄角旮旯(二)--寻找订阅端丢失的记录 Repli ...

  2. Vue 子组件向父组件传参

    直接上代码 <body> <div id="counter-event-example"> <p>{{ total }}</p> & ...

  3. 编码(Code)

    很遗憾,直接搜索Code或者编码是很难得找到这本书的,我也是无意中才接触到本书. 第一次读本书,对各方面的知识都不算很懂,觉得很多地方都写的太多浅显,好像本该就是这样子,一个编码系统说的那么麻烦干嘛, ...

  4. Java学习-009-文件名称及路径获取实例及源代码

    此文源码主要为应用 Java 获取文件名称及文件目录的源码及其测试源码.若有不足之处,敬请大神指正,不胜感激!源代码测试通过日期为:2015-2-3 00:02:27,请知悉. Java获取文件名称的 ...

  5. iOS - Swift Struct 结构体

    1.Struct 的创建 1.1 基本定义 结构体的定义 // 定义结构体数据类型 struct BookInfo { // 每个属性变量都必须初始化 var ID:Int = 0 var Name: ...

  6. Java程序员应该知道的10个面向对象理论

    英文原文:10-object-oriented-design-principles 面向对象理论是面向对象编程的核心,但是我发现大部分 Java 程序员热衷于像单例模式.装饰者模式或观察者模式这样的设 ...

  7. 关于adb重启的一些问题

    有时候我们在使用eclipse启动虚拟机进行程序测试的时候会提示,要我们重启adb和eclipse,这个时候,重启adb的方式就是,使用cmd定位到adb所在的文件夹,然后输入指令:adb kill- ...

  8. RepeatMasker使用中的问题

    RepeatMasker在运行时会先产生如下一个中间文件夹如RM_23346.WedAug301137422017,最后生成结果文件,例如.out,.masked,.tbl等 软件特性:软件运行很慢, ...

  9. js日常积累

    1.数组转字符串 str.join(',') 2.字符串转数组 arr.split(',') 3.数组排序 function sorb(a,b){return a-b;}; arr.sort(sorb ...

  10. HeatMap

    Reprinting From https://blog.csdn.net/JNingWei/article/details/78803669 ColorMap(色度图) 在图像处理中,伪色彩用途广泛 ...