hdu 1253 胜利大逃亡 (三维简单bfs+剪枝)

时间:2023-03-08 17:22:17

胜利大逃亡

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21449    Accepted Submission(s): 8442

Problem Description
Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.

魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.

hdu 1253 胜利大逃亡 (三维简单bfs+剪枝)

Input
输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)

特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.

Output
对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.

Sample Input
1
3 3 4 20
0 1 1 1
0 0 1 1
0 1 1 1
1 1 1 1
1 0 0 1
0 1 1 1
0 0 0 0
0 1 1 0
0 1 1 0
Sample Output
11
Author
Ignatius.L
Recommend

Ignatius.L

题意:有一个人要在魔王回来之前逃出城堡。1表示墙,0表示路。t表示魔王回来的时间。

感想:这题比较坑的一点是起点可以是墙,但是人能走出。而终点也可以是墙,那自然就走不出了,但是要判断。

剪枝:如果终点是门或者从起点到终点的最短时间都大于t ,直接输出 -1。

代码:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<queue>
using namespace std; int maps[55][55][55];
int a,b,c,t;
struct node
{
int x,y,z;
int steps;
}start;
int dx[]={0,0,0,0,-1,1};
int dy[]={0,0,-1,1,0,0};
int dz[]={-1,1,0,0,0,0}; bool in(node &now)
{
if(now.x>=1&&now.x<=a&&now.y>=1&&now.y<=b&&now.z>=1&&now.z<=c)
return true;
else return false;
} int bfs()
{
queue<node> q;
while(!q.empty())
q.pop();
q.push(start);
maps[start.x][start.y][start.z]=1;
node cur,next;
while(!q.empty())
{
cur=q.front();
q.pop();
if(cur.x==a&&cur.y==b&&cur.z==c&&cur.steps<=t)
return cur.steps;
for(int i=0;i<6;i++)
{
next.x=cur.x+dx[i];
next.y=cur.y+dy[i];
next.z=cur.z+dz[i];
if(in(next)&&next.x==a&&next.y==b&&next.z==c&&(cur.steps+1)<=t)
return cur.steps+1;
if(in(next)&&maps[next.x][next.y][next.z]==0)
{
next.steps=cur.steps+1;
//printf("test: %d %d %d %d\n",next.x,next.y,next.z,next.steps);
maps[next.x][next.y][next.z]=1;
q.push(next);
}
}
}
return -1;
} int main()
{
int n,i,j,k,flag;
scanf("%d",&n);
getchar();
while(n--)
{
scanf("%d%d%d%d",&a,&b,&c,&t);
getchar();
for(i=1;i<=a;i++)
{
for(j=1;j<=b;j++)
for(k=1;k<=c;k++)
{
scanf("%d",&maps[i][j][k]);
}
}
start.x=start.y=start.z=1;
start.steps=0;
if(a+b+c-3>t||maps[a][b][c]==1) //剪枝
flag=-1;
else
flag=bfs();
printf("%d\n",flag);
}
return 0;
} //AC /* 1
3 3 4 20
0 1 1 1
0 0 1 1
0 1 1 1
1 1 1 1
1 0 0 1
0 1 1 1
0 0 0 0
0 1 1 0
0 1 1 0 */

8752232

2013-07-29 14:03:48

Accepted

515MS

896K

1830 B

C++