POJ_2386 Lake Counting (dfs 错了一个负号找了一上午)

时间:2023-03-09 08:36:37
POJ_2386 Lake Counting (dfs 错了一个负号找了一上午)

来之不易的2017第一发ac

http://poj.org/problem?id=2386

Lake Counting
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 31474   Accepted: 15724

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS:

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

import java.util.Scanner;

public class Main{
int n,m;
static int N = 105, M =105;
static char field[][] = new char[N][M];
static int res = 0; static void dfs(int x, int y) {
field[x][y] = '.';
for(int dx=-1;dx<=1;dx++)
for(int dy=-1;dy<=1;dy++)
{
int nx=x+dx;
int ny=y+dy;
if(nx>=0&&nx<N&&ny>=0&&ny<M&&(field[nx][ny]=='W'))
dfs(nx,ny);
} return;
} public static void main(String[] args) {
Scanner cin = new Scanner(System.in);
N=cin.nextInt();
M=cin.nextInt();
String s;
for(int i=0;i<N;i++){
s = cin.next();
for(int j=0;j<M;j++)
field[i][j]=s.charAt(j);
} for(int i=0;i<N;i++){
for(int j=0;j<M;j++){
if(field[i][j]=='W'){
dfs(i,j);
res++;
}
}
}
System.out.println(res);
cin.close();
}
}