Triangular Sums

时间:2023-03-09 13:17:47
Triangular Sums

描述

The nth Triangular number, T(n) = 1 + … + n, is the sum of the first n integers. It is the number of points in a triangular array with n points on side. For example T(4):

X
X X
X X X
X X X X

Write a program to compute the weighted sum of triangular numbers:

W(n) = SUM[k = 1…nk * T(k + 1)]

输入
The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer n, (1 ≤ n ≤300), which is the number of points on a side of the triangle.

输出
For each dataset, output on a single line the dataset number (1 through N), a blank, the value of n for the dataset, a blank, and the weighted sum ,W(n), of triangular numbers for n.
样例输入
4
3
4
5
10
样例输出
1 3 45
2 4 105
3 5 210
4 10 2145
 import java.text.NumberFormat;
import java.util.Arrays;
import java.util.Scanner; public class Main {
public static void main(String[] args) {
Scanner scanner=new Scanner(System.in);
int T;
int n;
int k;
int i;
int temp;
int sum;
int time=1; T=scanner.nextInt();
while(true){
if(T==0)
break;
T--; n=scanner.nextInt(); sum=0;
for(k=1;k<=n;k++){
temp=0;
for(i=1;i<=k+1;i++)
temp+=i; sum+=k*temp;
}
System.out.println(time+" "+n+" "+sum);
time++;
}
}
}