poj 3259 Wormholes【spfa判断负环】

时间:2023-03-10 06:57:49
poj 3259 Wormholes【spfa判断负环】
Wormholes
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 36729   Accepted: 13444

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: NM, and W 
Lines 2..M+1 of each farm: Three space-separated numbers (SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2..M+W+1 of each farm: Three space-separated numbers (SET) that describe, respectively: A one way path from S to E that also moves the traveler back Tseconds.

Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

题意:John的农场里有n块地和m条路双向路以及w个虫洞,虫洞是一条单向路,不但会把你传送到目的地,而且时间会倒退T秒。我们的任务是知道会不会在从某块地出发后又回来,看到了离开之前的自己。

说下输入:n块地,m条边,w个虫洞。下面依次是m条边的信息(双向),输入完后是w个虫洞的信息(单向)。

思路:看图中有没有负权环,有的话John可以无限次走这个环,使得时间一定能得到一个负值。所以存在负环话就是可以,没有的话就是不可以了。

#include<stdio.h>
#include<string.h>
#include<queue>
#define MAX 20000
#define INF 0x3f3f3f
using namespace std;
int n,m,ans,s;
int beg,en;
int dis[MAX],vis[MAX];
int head[MAX];
int used[MAX];
struct node
{
int u,v,w;
int next;
}edge[MAX];
void init()
{
ans=0;
memset(head,-1,sizeof(head));
}
void add(int u,int v,int w)
{
edge[ans].u=u;
edge[ans].v=v;
edge[ans].w=w;
edge[ans].next=head[u];
head[u]=ans++;
}
void getmap()
{
int i,j;
scanf("%d%d%d",&n,&m,&s);
while(m--)
{
int a,b,c;
scanf("%d%d%d",&a,&b,&c);
add(a,b,c);
add(b,a,c);
}
while(s--)
{
int a,b,c;
scanf("%d%d%d",&a,&b,&c);
add(a,b,-c);
}
}
void spfa(int sx)
{
int i,j;
bool flag=false;
queue<int>q;
memset(vis,0,sizeof(vis));
memset(used,0,sizeof(used));
for(i=1;i<=n;i++)
dis[i]=INF;
vis[sx]=1;
dis[sx]=0;
used[sx]++;
q.push(sx);
while(!q.empty())
{
int u=q.front();
q.pop();
vis[u]=0;
for(i=head[u];i!=-1;i=edge[i].next)
{
int top=edge[i].v;
if(dis[top]>dis[u]+edge[i].w)
{
dis[top]=dis[u]+edge[i].w;
if(!vis[top])
{
vis[top]=1;
q.push(top);
used[top]++;
if(used[top]>n)//当一个点进队列大于n次则证明存在负环
{
flag=true;
break;
}
}
}
}
if(flag)
break;
}
if(!flag)
printf("NO\n");
else
printf("YES\n");
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
init();
getmap();
spfa(1);
}
return 0;
}