UVa 1025 A Spy in the Metro(动态规划)

时间:2023-03-09 02:45:55
UVa 1025 A Spy in the Metro(动态规划)

传送门

Description

Secret agent Maria was sent to Algorithms City to carry out an especially dangerous mission. After several thrilling events we find her in the first station of Algorithms City Metro, examining the time table. The Algorithms City Metro consists of a single line with trains running both ways, so its time table is not complicated. Maria has an appointment with a local spy at the last station of Algorithms City Metro. Maria knows that a powerful organization is after her. She also knows that while waiting at a station, she is at great risk of being caught. To hide in a running train is much safer, so she decides to stay in running trains as much as possible, even if this means traveling backward and forward. Maria needs to know a schedule with minimal waiting time at the stations that gets her to the last station in time for her appointment. You must write a program that finds the total waiting time in a best schedule for Maria. The Algorithms City Metro system has N stations, consecutively numbered from 1 to N. Trains move in both directions: from the first station to the last station and from the last station back to the first station. The time required for a train to travel between two consecutive stations is fixed since all trains move at the same speed. Trains make a very short stop at each station, which you can ignore for simplicity. Since she is a very fast agent, Maria can always change trains at a station even if the trains involved stop in that station at the same time.

UVa 1025 A Spy in the Metro(动态规划)

Input

The input file contains several test cases. Each test case consists of seven lines with information as follows. Line 1. The integer N (2 ≤ N ≤ 50), which is the number of stations. Line 2. The integer T (0 ≤ T ≤ 200), which is the time of the appointment. Line 3. N − 1 integers: t1, t2, . . . , tN−1 (1 ≤ ti ≤ 20), representing the travel times for the trains between two consecutive stations: t1 represents the travel time between the first two stations, t2 the time between the second and the third station, and so on. Line 4. The integer M1 (1 ≤ M1 ≤ 50), representing the number of trains departing from the first station. Line 5. M1 integers: d1, d2, . . . , dM1 (0 ≤ di ≤ 250 and di < di+1), representing the times at which trains depart from the first station. Line 6. The integer M2 (1 ≤ M2 ≤ 50), representing the number of trains departing from the N-th station. Line 7. M2 integers: e1, e2, . . . , eM2 (0 ≤ ei ≤ 250 and ei < ei+1) representing the times at which trains depart from the N-th station. The last case is followed by a line containing a single zero.

Output

For each test case, print a line containing the case number (starting with 1) and an integer representing the total waiting time in the stations for a best schedule, or the word ‘impossible’ in case Maria is unable to make the appointment. Use the format of the sample output.

Sample Input

4 55 5 10 15 4 0 5 10 20 4 0 5 10 15 4 18 1 2 3 5 0 3 6 10 12 6 0 3 5 7 12 15 2 30 20 1 20 7 1 3 5 7 11 13 17 0

Sample Output

Case Number 1: 5

Case Number 2: 0

Case Number 3: impossible

思路

  题意:

  某城市的地铁是线性的,有n(2≤n≤50)个车站,从左到右的编号为1~N.有M1辆列车从第一站开始往右开,还有M2辆列车从第n站开始往左开。在时刻0,Mario从第1站出发,目的是在时刻T(0≤T≤200)会见车站n的一个间谍。在车站等车容易被抓,所以她决定尽量躲在开动的火车上,让在车站等待的总时间尽量短。列车靠站停车时间忽略不计,且Mario身手敏捷,即使两辆方向不同的列车在同一时间靠站,Mario也能完成换乘。求最少等待时间。

  思路:

  Mario在某个状态都有三种决策:

    • 等一分钟。
    • 搭乘往右开的车(如果有)
    • 搭乘往左开的车(如果有)

      影响到当前决策的只有当前时间和所处的车站,所以可以用d(i,j)表示时刻i,你在车站j,最少还需要等待多长时间。边界条件d(T,n) = 0,其他d(T,j)为正无穷。

     

    /*
     *dp[i][j]表示时刻i,在车站j,最少还需要等待多长时间
     *has_train[t][i][0]表示时刻t,在车站i是否有向右开的火车
     *has_train[t][i][1]表示时刻t,在车站i是否有向左开的火车
     */
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    using namespace std;
    const int maxn = 55;
    const int maxt = 205;
    const int INF = 0x3f3f3f3f;
    int t[maxn],has_train[maxt][maxn][2],dp[maxt][maxn];
    int main()
    {
    	int n,Case = 0;
    	while (~scanf("%d",&n) && n)
    	{
    		int T,M1,M2,d;
    		memset(has_train,0,sizeof(has_train));
    		memset(dp,0,sizeof(dp));
    		scanf("%d",&T);
    		for (int i = 1;i < n;i++)	scanf("%d",&t[i]);
    		scanf("%d",&M1);
    		while (M1--)
    		{
    			scanf("%d",&d);
    			for (int j = 1;j < n;j++)
    			{
    				if (d <= T)	has_train[d][j][0] = 1;
    				d += t[j];
    			}
    		}
    		scanf("%d",&M2);
    		while (M2--)
    		{
    			scanf("%d",&d);
    			for (int j = n - 1;j > 0;j--)
    			{
    				if (d <= T)	has_train[d][j+1][1] = 1;
    				d += t[j];
    			}
    		}
    		for (int i = 1;i < n;i++)	dp[T][i] = INF;
    		dp[T][n] = 0;
    		for (int i = T - 1;i >= 0;i--)
    		{
    			for (int j =1;j <= n;j++)
    			{
    				dp[i][j] = dp[i+1][j] + 1;
    				if (j < n && has_train[i][j][0] && i + t[j] <= T)	dp[i][j] = min(dp[i][j],dp[i+t[j]][j+1]);
    				if (j > 1 && has_train[i][j][1] && i + t[j-1] <= T)	dp[i][j] = min(dp[i][j],dp[i+t[j-1]][j-1]);
    			}
    		}
    		printf("Case Number %d: ",++Case);
    		dp[0][1]>=INF ? printf("impossible\n"):printf("%d\n",dp[0][1]);
    	}
    	return 0;
    }