Power Network 分类: POJ 2015-07-29 13:55 3人阅读 评论(0) 收藏

时间:2022-08-04 22:16:38

Power Network

Time Limit: 2000MS Memory Limit: 32768K

Total Submissions: 24867 Accepted: 12958

Description

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= pmax(u) of power, may consume an amount 0 <= c(u) <= min(s(u),cmax(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= lmax(u,v) of power delivered by u to v. Let Con=Σuc(u) be the power consumed in the net. The problem is to compute the maximum value of Con.

An example is in figure 1. The label x/y of power station u shows that p(u)=x and pmax(u)=y. The label x/y of consumer u shows that c(u)=x and cmax(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and lmax(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6.

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of lmax(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of pmax(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of cmax(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.

Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20

7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7

(3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5

(0)5 (1)2 (3)2 (4)1 (5)4

Sample Output

15

6

Hint

The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second data set encodes the network from figure 1.

看了看最大流,在训练计划上找了一道题,敲敲,找找感觉;

#include <iostream>
#include <cmath>
#include <cstring>
#include <cstdlib>
#include <stdio.h>
#include <string>
#include <stack>
#include <queue>
#include <algorithm>
#include <map>
#define WW freopen("a1.txt","w",stdout) using namespace std; const int INF = 0x3f3f3f3f;
const int MAX = 110;
int resi[MAX][MAX];//残留网络
int h[MAX];//高度
int et[MAX];//余流
int s,t;//源点与汇点
int V;
int n,np,nc,m;
void push_relabel()//预流推进算法
{
int i,sum=0;
int u,v,p;
memset(h,0,sizeof(h));
h[s]=V;//将源点初始化点的个数,使源点的的层次为最大。
memset(et,0,sizeof(et));
et[s]=INF;//将起始点的余流设置为无穷大;
et[t]=-INF;
deque<int>act;//活动定点队列
act.push_front(s);
while(!act.empty())
{
u=act.back();
act.pop_back();
for(i=0; i<V; i++)
{
v=i;
p=min(resi[u][v],et[u]);//获得最小的余流
if(p>0&&(u==s||h[u]==h[v]+1))
{
resi[u][v]-=p;
resi[v][u]+=p;
if(v==t)
{
sum+=p;
}
et[u]-=p;
et[v]+=p;
if(v!=s&&v!=t)
{
act.push_front(v);
}
}
}
if(u!=s&&u!=t&&et[u]>0)//如果这个点不是源点与汇点且余流不为零,则将他的层次升高;
{
h[u]++;
act.push_front(u);
}
}
printf("%d\n",sum);
}
int main()
{
int u,v,z;
while(~scanf("%d %d %d %d",&n,&np,&nc,&m))
{
s=n;
t=n+1;//因为没有源点与汇点所以要自己设置汇点与源点
V=n+2;
memset(resi,0,sizeof(resi));
for(int i=0; i<m; i++)
{
while(getchar()!='(');
scanf("%d,%d)%d",&u,&v,&z);
resi[u][v]=z;
}
for(int i=0; i<np; i++)
{
while(getchar()!='(');
scanf("%d)%d",&u,&z);
resi[s][u]=z;//将所有的生产力放在源点
}
for(int i=0; i<nc; i++)
{
while(getchar()!='(');
scanf("%d)%d",&u,&z);
resi[u][t]=z;//将所有的消耗放在汇点
}
push_relabel();
}
return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。