poj 2096 Collecting Bugs 概率dp 入门经典 难度:1

时间:2023-03-08 19:54:54
Collecting Bugs
Time Limit: 10000MS   Memory Limit: 64000K
Total Submissions: 2745   Accepted: 1345
Case Time Limit: 2000MS   Special Judge

Description

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program. 
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category. 
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It's important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan's opinion about the reliability of the obsolete version. 
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem. 
Find an average time (in days of Ivan's work) required to name the program disgusting.

Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).

Output

Output the expectation of the Ivan's working days needed to call the program disgusting, accurate to 4 digits after the decimal point.

Sample Input

1 2

Sample Output

3.0000

感想:一开始列出公式不知道干什么,但是实际上,从n,s的状态向0,0状态逆着递推,当n,s状态时,一步也不需要移动,否则因为后面的状态已经不会影响到前面的状态,直接转移,感觉这个实在是概率dp;当时遇到的打开新思路的一道题
思路:dp[i][j]代表已经得到i种bug,j个子项目有bug,达成目标所需的最少次数,那么dp[n][s]明显为0,其余的某种状态dp[i][j],只可能最多向四种情况转移,也就是dp[i][j],概率为i*j/n/s,dp[i][j+1]概率为i*(s-j)/n/s,dp[i+1][j]概率为(n-i)*j/n/s,dp[i+1][j+1],概率为(n-i)*(s-j)/n/s,现在其它三种状态((i+1,j),(i,j+1),(i+1,j+1))都得到了,于是dp[i][j]就是唯一的未知量,可以解出来

  dp[i][j]=1+dp[i+1][j]*j*(n-i)/n/s+dp[i][j+1]*i*(s-j)/n/s+dp[i+1][j+1]*(s-j)*(n-i)/n/s+dp[i][j]*i*j/n/s;

#include <cstdio>
#include <cstring>
using namespace std;
int n,s;
double dp[1001][1001];
int main(){
while(scanf("%d%d",&n,&s)==2){
memset(dp,0,sizeof(dp));
for(int i=n;i>=0;i--){
for(int j=s;j>=0;j--){
if(i==n&&j==s)continue;
dp[i][j]=1+dp[i+1][j]*j*(n-i)/n/s+dp[i][j+1]*i*(s-j)/n/s+dp[i+1][j+1]*(s-j)*(n-i)/n/s;
double p=1-(double)i*j/n/s;
dp[i][j]/=p;
}
}
printf("%.4f\n",dp[0][0]);
}
}