2017ecjtu-summer training #1 UVA 10399

时间:2023-03-09 14:27:14
2017ecjtu-summer training #1  UVA 10399

It has been said that a watch that is stopped keeps better time than one that loses 1 second per day.

The one that is stopped reads the correct time twice a day while the one that loses 1 second per day is correct only once every 43,200 days.

This maxim applies to old fashioned 12-hour analog watches, whose hands move continuously (most digital watches would display nothing at all if stopped).

Given two such analog watches, both synchronized to midnight, that keep time at a constant rate but run slow by k and m seconds per day respectively, what time will the watches show when next they have exactly the same time?

Input

Input consists of a number of lines, each with two distinct non-negative integers k and m between 0 and 256, indicating the number of seconds per day that each watch loses.

Output

For each line of input, print k, m, and the time displayed on each watch, rounded to the nearest minute. Valid times range from 01:00 to 12:59.

Sample Input

1 2

0 7

Sample Output

1 2 12:00

0 7 10:17

题意 两个表一个表一天慢k秒,另一个表一天慢m秒,问下一次相同的时间是多少

表的一圈是43200秒,一天是86400秒

追及问题 经过43200/m-k天再次时间一样

此时 表走了( 43200/m-k )*( 86400-k )秒

AC代码

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <sstream>
#include <queue>
#include <vector>
#include <algorithm>
#define maxn 100010
using namespace std;
typedef long long ll;
int main()
{
int k,m;
int min,h;
while(scanf("%d%d",&k,&m)!=EOF)
{
int a=abs(m-k);
ll s=(ll)(43200.0/a*(86400.0-k));
s%=; //这些天转了s/43200圈后剩余的秒数
int min=s/; //求出分钟数
s%=; //rounded to the nearest minute
if(s>=)
min++;
int h=min/; //求出小时数
min%=; // 分的时间
h%=; // 没有0点换成12点
if(h==)
h=;
printf("%d %d %02d:%02d\n", k, m, h, min);//格式输出
}
}