Tom and paper

时间:2022-11-21 15:45:10

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5224

题意:

给出矩形的面积,求出最小的周长。

样例:

Sample Input

3
2
7
12
 

Sample Output

6
16
14
思路:
这个题只需要注意时间就可以了。
  刚开始就就是直接从1开始循环找出满足条件的后比较,结果超时了。。。。
后来又开始从n/2开始查找,这个不需要比较只要找到满足条件就可以了可是还是超时了。。。。
最后是从sqrt()开始才过的。
 #include<iostream>
#include<cmath>
using namespace std;
int i;
int main()
{
int t,n;
cin>>t;
while(t--)
{
cin>>n;
int m;
for(i=sqrt(n);i<=n;i++)
{
if(n%i==)
{ m=i+n/i;
break;
}
}
cout<<m*<<endl;
}
return ;
}