BestCoder#15 A-LOVE(暴力)

时间:2021-07-12 23:20:16

Love

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 123    Accepted Submission(s): 90

Problem Description
There is a Love country with many couples of Darby and Joan in it. In order to commemorate their love, they will do some thing special when giving name to their offspring. 
When a couple want to give name to their offspring, they will firstly get their first names, and list the one of the male before the one of the female. Then insert the string “small” between their first names. Thus a new name is generated. For example, the first name of male is Green, while the first name of the female is Blue, then the name of their offspring is Green small Blue.
You are expected to write a program when given the name of a couple, output the name of their offsping.
 
Input
Multi test cases (about 10), every case contains two lines. 
The first line lists the name of the male.
The second line lists the name of the female.
In each line the format of the name is [given name]_[first name].
Please process to the end of file.

[Technical Specification]
3 ≤ the length of the name ≤ 20
[given name] only contains alphabet characters and should not be empty, as well as [first name].

 
Output
For each case, output their offspring’s name in a single line in the format [first name of male]_small_[first name of female].
 
Sample Input
Jim_Green
Alan_Blue
 
Sample Output
Green_small_Blue
 
Source
 水题,没思想,不过用java写稍微快点
 import java.io.*;
import java.util.*;
import java.text.*;
public class BestCoder15 {
public static void main(String[] args){
Scanner sc = new Scanner(new InputStreamReader(System.in)); while(sc.hasNextLine()){
String s1 = new String(sc.nextLine());
String s2 = new String(sc.nextLine()); String[] str1 = s1.split("_");
String[] str2 = s2.split("_"); System.out.println(str1[1] + "_small_" + str2[1]);
}
sc.close();
}
}