HDU 1002 A + B Problem II

时间:2022-04-26 23:46:46

A + B Problem II

  Time Limit: 1000MS      Memory Limit: 65536K

Total Submissions: 16104    Accepted: 4547

Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

思路:

把数值每一位拆开存进数组,利用ASCII码转换数据,然后进行相加。

#include<stdio.h>
#include<string.h>
int main()
{
    char a[1003];
    char b[1003];
    char ans[1003];
    int T;
    scanf("%d",&T);
    int cas = 0 ;
    while(T--)
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(ans,0,sizeof(ans));
        scanf("%s",a);
        scanf("%s",b);
        strrev(a);
        strrev(b);
        int i;
        for(i = 0 ; a[i]&&b[i];i++)
        {
            ans[i]+=a[i]+b[i]-48;
            if(ans[i]>'9'){
            ans[i+1]++;
            ans[i]-=10;
            }
        }
        while(a[i]){
            ans[i]+=a[i];
            if(ans[i]>'9'){
            ans[i+1]++;
            ans[i]-=10;
            }
            i++;
        }
        while(b[i]){
            ans[i]+=b[i];
            if(ans[i]>'9'){
            ans[i+1]++;
            ans[i]-=10;
            }
            i++;
        }
        if(ans[i]==1)ans[i]+=48;
        strrev(ans);
        strrev(a);
        strrev(b);
        if(cas)printf("\n");
        printf("Case %d:\n",++cas);
        printf("%s + %s = %s\n",a,b,ans);
    }
}