HDU_2055——刷题不要使用fflush()

时间:2022-02-14 23:29:02
Problem Description
we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26; Give you a letter x and a number y , you should output the result of y+f(x).
Input
On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.
Output
for each case, you should the result of y+f(x) on a line.
Sample Input
6 R 1 P 2 G 3 r 1 p 2 g 3
Sample Output
19 18 10 -17 -14 -4
 #include <cstdio>
int main()
{
int T, n;
char ch;
scanf("%d",&T);
while(T--)
{
//fflush(stdin);//切记不能使用这个..
getchar();
scanf("%c %d",&ch,&n);
if(ch>='a'&&ch<='z')
{
printf("%d\n",n+(-ch));
}
else
{
printf("%d\n",n+(ch-));
}
}
return ;
}