poj 2155:Matrix(二维线段树,矩阵取反,好题)

时间:2023-03-08 15:46:07
Matrix
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 17880   Accepted: 6709

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above.

Output

For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

Source

POJ Monthly,Lou Tiancheng

  二维线段树,矩阵取反,好题
  题意
  poj 2155:Matrix(二维线段树,矩阵取反,好题)
  思路
  矩阵节点的值为是否取反,0为不取反,1为取反,暂称为取反值。
  取反操作的时候先找到这个矩阵代表的节点,然后将这个节点的值+1再模2,即取反。
  查询的时候,将(x,y)这个坐标经过的所有矩阵的取反值加起来,每次%2,最后那个值就为这个坐标最后的值。
  为什么%2,因为不是1就是0,矩阵记录了取反值,找这个坐标的过程中,经过的矩阵如果取反值为1,则结果变为0,在经过一个取反值为1的矩阵,结果又变为1…… 直到加到要找的坐标的取反值,这个结果记录的值就是这个坐标的取反值。这个时候输出结果。
  代码
 #include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std; #define MAXN 1100 int tree[MAXN*][MAXN*],s; void Negate_y(int d,int dy,int L,int R,int y1,int y2) //取反操作
{
if(L==y1 && R==y2){ //将这个矩阵的所有元素记录为取反
tree[d][dy] = (tree[d][dy]+) % ;
return ;
} int mid = (L+R)>>;
if(mid>=y2)
Negate_y(d,dy<<,L,mid,y1,y2);
else if(mid<y1)
Negate_y(d,dy<<|,mid+,R,y1,y2);
else{
Negate_y(d,dy<<,L,mid,y1,mid);
Negate_y(d,dy<<|,mid+,R,mid+,y2);
}
} void Negate_x(int d,int L,int R,int x1,int y1,int x2,int y2) //取反操作
{
if(L==x1 && R==x2){ //找到行块
Negate_y(d,,,s,y1,y2);
return ;
} int mid = (L+R)>>;
if(mid>=x2)
Negate_x(d<<,L,mid,x1,y1,x2,y2);
else if(mid<x1)
Negate_x(d<<|,mid+,R,x1,y1,x2,y2);
else{
Negate_x(d<<,L,mid,x1,y1,mid,y2);
Negate_x(d<<|,mid+,R,mid+,y1,x2,y2);
}
} int Query_y(int d,int dy,int L,int R,int r) //查询
{
if(L==R) //找到要找的坐标,输出这个坐标对应的值
return tree[d][dy]; //没找到
int mid = (L+R)>>;
if(mid >= r)
return (Query_y(d,dy<<,L,mid,r)+tree[d][dy]) % ;
else
return (Query_y(d,dy<<|,mid+,R,r)+tree[d][dy]) % ;
} int Query_x(int d,int L,int R,int l,int r) //查询
{
if(L==R){ //找到要找的行块,继续查找列块
return Query_y(d,,,s,r);
} //没找到
int mid = (L+R)>>;
if(mid >= l)
return (Query_x(d<<,L,mid,l,r) + Query_y(d,,,s,r)) % ;
else
return (Query_x(d<<|,mid+,R,l,r) + Query_y(d,,,s,r)) % ;
} int main()
{
int X,T,x,y,x1,y1,x2,y2;
scanf("%d",&X);
while(X--){
memset(tree,,sizeof(tree));
scanf("%d%d",&s,&T);
while(T--){
char c[];
scanf("%s",c);
if(c[]=='C'){
scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
Negate_x(,,s,x1,y1,x2,y2);
}
else if(c[]=='Q'){
scanf("%d%d",&x,&y);
printf("%d\n",Query_x(,,s,x,y));
}
}
if(X!=)
printf("\n");
} return ;
}

Freecode : www.cnblogs.com/yym2013