POJ 1O17 Packets [贪心]

时间:2023-03-10 05:11:46
POJ 1O17 Packets [贪心]

Packets

Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.

Sample Input

0 0 4 0 0 1
7 5 1 0 0 0
0 0 0 0 0 0

Sample Output

2
1

题意:给出1*1 2*2......6*6的方块,全部放入6*6的箱子中,问最少需要多少个箱子。

题解:(先考虑最大的)

1.若一个箱子中有4*4或者5*5或者6*6的方块,则不能装入其他的方块,统计共有 多少个这样的方块。

2.若放入3*3的方块 需要多少个箱子,余下的空位能够放入几个2*2的方块。

3.看之前剩余的空位能否把2*2的填完,否则另加箱子。

4.统计1-3的空位 能否把1*1的填满 否则另加箱子。

代码:

#include<stdio.h>
int main()
{
int a[4]={0,5,3,1};//一个6*6的箱子中装入i个3*3的箱子时 剩余的空间可装入2*2的个数
int s1,s2,s3,s4,s5,s6;
while(scanf("%d%d%d%d%d%d",&s1,&s2,&s3,&s4,&s5,&s6)!=EOF)
{
if(s1+s2+s3+s4+s5+s6==0)
break;
int cnt=s4+s5+s6+(s3+3)/4;
int m=s4*5+a[s3%4];//多出的位置能放置2*2的个数
if(m<s2)
{
cnt+=(s2-m+8)/9;
}
int n=cnt*36-s6*36-s5*25-s4*16-s3*9-s2*4;
if(n<s1)
{
cnt+=(s1-n+35)/36;
}
printf("%d\n",cnt);
}
}