HDU 3416 Marriage Match IV (求最短路的条数,最大流)

时间:2022-04-26 16:58:05

Marriage Match IV

题目链接:

http://acm.hust.edu.cn/vjudge/contest/122685#problem/Q

Description


Do not sincere non-interference。
Like that show, now starvae also take part in a show, but it take place between city A and B. Starvae is in city A and girls are in city B. Every time starvae can get to city B and make a data with a girl he likes. But there are two problems with it, one is starvae must get to B within least time, it's said that he must take a shortest path. Other is no road can be taken more than once. While the city starvae passed away can been taken more than once.
So, under a good RP, starvae may have many chances to get to city B. But he don't know how many chances at most he can make a data with the girl he likes . Could you help starvae?

Input


The first line is an integer T indicating the case number.(1

Output


Output a line with a integer, means the chances starvae can get at most.

Sample Input


```
3
7 8
1 2 1
1 3 1
2 4 1
3 4 1
4 5 1
4 6 1
5 7 1
6 7 1
1 7

6 7

1 2 1

2 3 1

1 3 3

3 4 1

3 5 1

4 6 1

5 6 1

1 6

2 2

1 2 1

1 2 2

1 2

</big>

##Sample Output
<big>
2
1
1
</big> ##Hint
<big>
</big> <br/>
##题意:
<big>
求最短路的条数.
要求这些路径互相没有相同的边.
</big> <br/>
##题解:
<big>
由于要求同一条边不能出现在两条最短路中.
所以直接标记出最短路中的边,对这些边跑一次最大流即可. (这里直接用了sap模版)
<br/>
若这个题没有不共边的要求,就直接对最短路中的边dfs即可.
[HDU1142-A Walk Through the Forest](http://acm.hdu.edu.cn/showproblem.php?pid=1142)
题解:http://www.cnblogs.com/Sunshine-tcf/p/5752205.html
</big> <br/>
##代码:
``` cpp
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>
#include <set>
#include <vector>
#define LL long long
#define eps 1e-8
#define maxn 501000
#define mod 1000000007
#define inf 0x3f3f3f3f
#define IN freopen("in.txt","r",stdin);
using namespace std; int n, m;
typedef pair<int,int> pii;
priority_queue<pii,vector<pii>,greater<pii> > q;
bool vis[maxn];
int edges, u[maxn], v[maxn], w[maxn];
int first[maxn], _next[maxn];
int dist[maxn];
int pre1[maxn]; void add_edge(int s, int t, int val) {
u[edges] = s; v[edges] = t; w[edges] = val;
_next[edges] = first[s];
first[s] = edges++;
} void dijkstra(int s) {
memset(pre1, -1, sizeof(pre1));
memset(vis, 0, sizeof(vis));
for(int i=1; i<=n; i++) dist[i]=inf; dist[s] = 0;
while(!q.empty()) q.pop();
q.push(make_pair(dist[s], s)); while(!q.empty()) {
pii cur = q.top(); q.pop();
int p = cur.second;
if(vis[p]) continue; vis[p] = 1;
for(int e=first[p]; e!=-1; e=_next[e]) if(dist[v[e]] > dist[p]+w[e]){
dist[v[e]] = dist[p] + w[e];
q.push(make_pair(dist[v[e]], v[e]));
pre1[v[e]] = p;
}
}
} //最大流SAP
struct Node {
int to,_next,cap;
}edge[maxn];
int tol;
int head[maxn];
int gap[maxn],dis[maxn],pre[maxn],cur[maxn];
void init() {
tol=0;
memset(head,-1,sizeof(head));
}
void addedge(int u,int v,int w,int rw=0) {
edge[tol].to=v;edge[tol].cap=w;edge[tol]._next=head[u];head[u]=tol++;
edge[tol].to=u;edge[tol].cap=rw;edge[tol]._next=head[v];head[v]=tol++;
} int sap(int start,int end,int nodenum)
{
memset(dis,0,sizeof(dis));
memset(gap,0,sizeof(gap));
memcpy(cur,head,sizeof(head));
int u=pre[start]=start,maxflow=0,aug=-1;
gap[0]=nodenum;
while(dis[start]<nodenum)
{
loop:
for(int &i=cur[u];i!=-1;i=edge[i]._next)
{
int v=edge[i].to;
if(edge[i].cap&&dis[u]==dis[v]+1)
{
if(aug==-1||aug>edge[i].cap)
aug=edge[i].cap;
pre[v]=u;
u=v;
if(v==end)
{
maxflow+=aug;
for(u=pre[u];v!=start;v=u,u=pre[u])
{
edge[cur[u]].cap-=aug;
edge[cur[u]^1].cap+=aug;
}
aug=-1;
}
goto loop;
}
}
int mindis=nodenum;
for(int i=head[u];i!=-1;i=edge[i]._next)
{
int v=edge[i].to;
if(edge[i].cap&&mindis>dis[v])
{
cur[u]=i;
mindis=dis[v];
}
}
if((--gap[dis[u]])==0)break;
gap[dis[u]=mindis+1]++;
u=pre[u];
}
return maxflow;
} int main(void)
{
//IN; int t; cin >> t; int ca = 1;
while(t--)
{
memset(first, -1, sizeof(first)); edges = 0;
cin >> n >> m; while(m--) {
int u,v,w; scanf("%d %d %d", &u, &v, &w);
if(u == v) continue;
add_edge(u, v, w);
}
int s, t; cin >> s >> t; dijkstra(s); init();
for(int e=0; e<edges; e++) {
//判断是否是最短路上的边
if(dist[v[e]] == dist[u[e]]+w[e]) {
addedge(u[e], v[e], 1);
}
} int paths = sap(s, t, n); printf("%d\n", paths);
} return 0;
}

HDU 3416 Marriage Match IV (求最短路的条数,最大流)的更多相关文章

  1. hdu 3416 Marriage Match IV (最短路&plus;最大流)

    hdu 3416 Marriage Match IV Description Do not sincere non-interference. Like that show, now starvae ...

  2. HDU 3416 Marriage Match IV(最短路,网络流)

    题面 Do not sincere non-interference. Like that show, now starvae also take part in a show, but it tak ...

  3. HDU 3416 Marriage Match IV 【最短路】&lpar;记录路径&rpar;&plus;【最大流】

    <题目链接> 题目大意: 给你一张图,问你其中没有边重合的最短路径有多少条. 解题分析: 建图的时候记得存一下链式后向边,方便寻找最短路径,然后用Dijkstra或者SPFA跑一遍最短路, ...

  4. hdu 3416 Marriage Match IV 【 最短路 最大流 】

    求边不可重复的最短路条数 先从起点到终点用一次dijkstra,再从终点到起点用一次dijkstra,来判断一条边是否在最短路上 如果在,就将这条边的两个端点连起来,容量为1 再跑一下dinic(), ...

  5. HDU 3416 Marriage Match IV (最短路径,网络流,最大流)

    HDU 3416 Marriage Match IV (最短路径,网络流,最大流) Description Do not sincere non-interference. Like that sho ...

  6. HDU 3416 Marriage Match IV(ISAP&plus;最短路)题解

    题意:从A走到B,有最短路,问这样不重复的最短路有几条 思路:先来讲选有效边,我们从start和end各跑一次最短路,得到dis1和dis2数组,如果dis1[u] + dis2[v] + cost[ ...

  7. HDU 3416 Marriage Match IV &lpar;最短路建图&plus;最大流)

    (点击此处查看原题) 题目分析 题意:给出一个有n个结点,m条单向边的有向图,问从源点s到汇点t的不重合的最短路有多少条,所谓不重复,意思是任意两条最短路径都不共用一条边,而且任意两点之间的边只会用一 ...

  8. HDU 3416 Marriage Match IV (Dijkstra&plus;最大流)

    题意:N个点M条边的有向图,给定起点S和终点T,求每条边都不重复的S-->T的最短路有多少条. 分析:首先第一步需要找出所有可能最短路上的边.怎么高效地求出呢?可以这样:先对起点S,跑出最短路: ...

  9. HDU 3416 Marriage Match IV

    最短路+最大流 #include<cstdio> #include<cstring> #include<string> #include<cmath> ...

随机推荐

  1. HDU 1863 畅通工程&lpar;最小生成树,prim&rpar;

    题意: 给出图的边和点数,要求最小生成树的代价,注:有些点之间是不可达的,也就是可能有多个连通图.比如4个点,2条边:1-2,3-4. 思路: 如果不能连通所有的点,就输出‘?’.之前以为每个点只要有 ...

  2. linux-0&period;11抠代码-GDB&plus;VMWARE

    vmware新建一个虚拟机,硬盘为0.1G,建立完成后要先启动一次虚拟机,此时无任何系统,然后再关闭,应该会多出一个ostest-flat.vmdk这个虚拟磁盘文件,下面要用到 新建完成后 我的虚拟机 ...

  3. bootstrap 栅格系统 自动隐藏

    1 Container 顾名思义Container是栅格系统最外层的class,直接被container包裹的只能是row这个class.需要注意的是container自带左右各15px paddin ...

  4. SqlBulkCopy简单封装,让批量插入更方便

    关于 SqlServer 批量插入的方式,前段时间也有大神给出了好几种批量插入的方式及对比测试(http://www.cnblogs.com/jiekzou/p/6145550.html),估计大家也 ...

  5. Ubuntu 追加组&comma;用户,设置免sudo密码输入

    1,以root权限执行groupadd命令创建dev组.     sudo groupadd dev 2,用adduser命令创建bpuser用户,--ingroup指定用户加入dev组.   sud ...

  6. e614&period; Setting the Initial Focused Component in a Window

    There is no straightforward way to set the initial focused component in a window. The typical method ...

  7. 通过java的i&sol;o机制进行图片流的存储以及对网络图片的存储

    存储内地图片思路:首先把原有的图片以流的方式读取出来,再以流的方式存储到目标文件: package imgStream; import java.io.*; public class ImgStrea ...

  8. mp4网页播放代码,有声音无图像的解决办法~

    mp4网页播放代码,有声音无图像的解决办法~     关于网页播放mp4格式的视频,找了一些插件,这里推荐一下video.js 官方网址:http://www.videojs.com/ github ...

  9. cf1043C&period; Smallest Word&lpar;贪心&rpar;

    题意 题目链接 Sol 这题打cf的时候真的是脑残,自己造了个abcdad的数据开心的玩了半天一脸懵逼...最后还好ycr大佬给了个思路不然就凉透了... 首先不难看出我们最后一定可以把字符串弄成\( ...

  10. 利用FluidMoveBehavior制作出手机通讯录平滑的效果

    最近学习Blend,原来Blend制作动画等效果非常棒.下面演示一下FluidMoveBehavior应用,利用Blend中行为中的FluidMoveBehavior制作出手机通讯录平滑的效果 1.在 ...