hdu1018 Big Number 斯特林公式 求N!的位数。

时间:2023-03-10 01:01:32
hdu1018 Big Number 斯特林公式 求N!的位数。

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 37732    Accepted Submission(s): 18174

Problem Description
In
many applications very large integers numbers are required. Some of
these applications are using keys for secure transmission of data,
encryption, etc. In this problem you are given a number, you have to
determine the number of digits in the factorial of the number.
Input
Input
consists of several lines of integer numbers. The first line contains
an integer n, which is the number of cases to be tested, followed by n
lines, one integer 1 ≤ n ≤ 107 on each line.
Output
The output contains the number of digits in the factorial of the integers appearing in the input.
Sample Input
2
10
20
Sample Output
7
19
Source
/**
题目:Big Number
链接:http://acm.hdu.edu.cn/showproblem.php?pid=1018
题意:求n!的位数。
思路:
斯特林公式:LL res=(long)( (log10(sqrt(4.0*acos(0.0)*n)) + n*(log10(n)-log10(exp(1.0)))) + 1 );
注意:当n=1的时候,公式不成立。自己算。 */
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
typedef long long LL;
const int mod=1e9+;
const int maxn=1e6+;
int T, n;
int main()
{
cin>>T;
while(T--)
{
scanf("%d",&n);
if(n==){
printf("1\n"); continue;
}
LL res=(long)( (log10(sqrt(4.0*acos(0.0)*n)) + n*(log10(n)-log10(exp(1.0)))) + );
printf("%lld\n",res);
}
return ;
}