poj 1321 棋盘问题 递归运算

时间:2023-03-08 21:54:31
poj 1321 棋盘问题 递归运算
棋盘问题
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 19935   Accepted: 9933

Description

在一个给定形状的棋盘(形状可能是不规则的)上面摆放棋子,棋子没有区别。要求摆放时任意的两个棋子不能放在棋盘中的同一行或者同一列,请编程求解对于给定形状和大小的棋盘,摆放k个棋子的所有可行的摆放方案C。

Input

输入含有多组测试数据。 
每组数据的第一行是两个正整数,n k,用一个空格隔开,表示了将在一个n*n的矩阵内描述棋盘,以及摆放棋子的数目。 n <= 8 , k <= n 

当为-1 -1时表示输入结束。 

随后的n行描述了棋盘的形状:每行有n个字符,其中 # 表示棋盘区域, . 表示空白区域(数据保证不出现多余的空白行或者空白列)。 

Output

对于每一组数据,给出一行输出,输出摆放的方案数目C (数据保证C<2^31)。

Sample Input

2 1
#.
.#
4 4
...#
..#.
.#..
#...
-1 -1

Sample Output

2
1

Source Code

Problem: 1321
Memory: 204K Time: 16MS
Language: C++ Result: Accepted
Source Code
#include<iostream>
#include<math.h>
using namespace std;
int sum=0;
int n,k;
int x[9];
char mg[9][9];
bool place(int f)
{
for(int j=0;j<f;j++)
if(x[j]==x[f])
return false;
return true;
}
void backtrack(int t,int count)
{
if(count==k)
{
sum++;
return;
}
if(t>=n || (n-t)+count<k)
return;
for(int i=0;i<n;i++)
{
x[t]=i;
if(mg[t][i]=='#' && place(t))
backtrack(t+1,count+1);;
}
x[t]=-1;
backtrack(t+1,count);
}
int main()
{
while(true)
{
scanf("%d %d",&n,&k);
if(n==-1 && k==-1)
break;
for(int i=0;i<n;i++)
scanf("%s",mg[i]);
backtrack(0,0);
printf("%d\n",sum);
sum=0;
}
system("pause");
return 0;
}