HDU 4391 Paint The Wall(分块+延迟标记)

时间:2023-03-09 16:57:52
HDU 4391 Paint The Wall(分块+延迟标记)

Paint The Wall

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3427    Accepted Submission(s): 955

Problem Description
As a amateur artist, Xenocide loves painting the wall. The wall can be considered as a line consisting of n nodes. Each node has its own color.

Xenocide spends all day in front of the wall. Sometimes, he paints some consecutive nodes so that these nodes have the same color. When he feels tired, he focuses on a particular color and counts the number of nodes that have this color within a given interval.

Now Xenocide is tired of counting, so he turns to you for help.

Input
The input consists of several test cases.
The first line of each test case contains two integer n, m(1<=n, m<=100000) indicating the length of the wall and the number of queries.
The following line contains N integers which describe the original color of every position.
Then m lines follow. Each line contains 4 non-negative integers a, l, r, z(1<=a<=2, 0<=l<=r<n ,0<=z<231).
a = 1 indicates that Xenocide paints nodes between l and r and the resulting color is z.
a = 2 indicates that Xenocide wants to know how many nodes between l and r have the color z.
Output
Print the corresponding answer for each queries.
Sample Input
5 5
1 2 3 4 0
2 1 3 3
1 1 3 1
2 1 3 3
2 0 3 1
2 3 4 1
Sample Output
1
4
1

题目链接:HDU 4391

一开始一看以为是线段树,虽然这题有很多人线段树+剪枝过的,如果用的是区间最大值最小值剪枝,粗略一想确实剪枝挺强,它用了一种二分的思想——区间大小跟最大值最小值之差肯定是存在单调不减的关系,但是对于特殊数据就没戏了,比如151515151515,然后查询1,n,3,这样一来3确实一直在1~5之间,但是会一直递归到根节点,最后却连发现一个3都没有,因此这题正解之一应该是分块算法,每一个块维护这个块所控制区间的颜色及每一个颜色的数量信息,此处有分块的区间更新操作,因此需要lazy的思想,跟线段树一样,整块打标记,标记传递时把信息传递到真实数组里去,学习一个分块下的延迟标记的用法,最后注意一下题目中的数组都是从0开始的

代码:

#include <bits/stdc++.h>
using namespace std;
#define INF 0x3f3f3f3f
#define LC(x) (x<<1)
#define RC(x) ((x<<1)+1)
#define MID(x,y) ((x+y)>>1)
#define CLR(arr,val) memset(arr,val,sizeof(arr))
#define FAST_IO ios::sync_with_stdio(false);cin.tie(0);
typedef pair<int, int> pii;
typedef long long LL;
const double PI = acos(-1.0);
const int N = 100010;
const int M = sqrt(N) + 10;
struct block
{
int color, l, r;
map<int, int>info;
inline int len()
{
return r - l + 1;
}
};
block B[M];
int arr[N], belong[N];
int unit, bcnt; void init(int n)
{
unit = sqrt(n);
bcnt = n / unit;
if (n % unit)
++bcnt;
for (int i = 1; i <= bcnt; ++i)
{
B[i].l = (i - 1) * unit + 1;
B[i].r = i * unit;
B[i].color = -1;
B[i].info.clear();
}
B[bcnt].r = n;
for (int i = 1; i <= n; ++i)
{
belong[i] = (i - 1) / unit + 1;
++B[belong[i]].info[arr[i]];
}
}
void pushdown(int x)
{
if (~B[x].color)
{
for (int i = B[x].l; i <= B[x].r; ++i)
arr[i] = B[x].color;
B[x].info.clear();
B[x].info[B[x].color] = B[x].len();
B[x].color = -1;
}
}
void update(int l, int r, int c)
{
int bl = belong[l], br = belong[r];
for (int i = bl + 1; i < br; ++i)
B[i].color = c;
if (bl != br)
{
pushdown(bl);
pushdown(br);
for (int i = l; i <= B[bl].r; ++i)
{
--B[bl].info[arr[i]];
++B[bl].info[c];
arr[i] = c;
}
for (int i = B[br].l; i <= r; ++i)
{
--B[br].info[arr[i]];
++B[br].info[c];
arr[i] = c;
}
}
else
{
pushdown(bl);
for (int i = l; i <= r; ++i)
{
--B[bl].info[arr[i]];
++B[bl].info[c];
arr[i] = c;
}
}
}
int query(int l, int r, int c)
{
int ret = 0;
int bl = belong[l], br = belong[r];
for (int i = bl + 1; i < br; ++i) //先处理中间
{
if (~B[i].color)
ret += B[i].len() * (B[i].color == c);
else
{
if (B[i].info.find(c) != B[i].info.end())
ret += B[i].info[c];
}
}
if (bl == br)
{
pushdown(bl);
for (int i = l; i <= r; ++i)
ret += (arr[i] == c);
}
else
{
pushdown(bl);
pushdown(br);
for (int i = l; i <= B[bl].r; ++i)
ret += (arr[i] == c);
for (int i = B[br].l; i <= r; ++i)
ret += (arr[i] == c);
}
return ret;
}
int main(void)
{
int n, m, a, l, r, z, i;
while (~scanf("%d%d", &n, &m))
{
for (i = 1; i <= n; ++i)
scanf("%d", &arr[i]);
init(n);
while (m--)
{
scanf("%d%d%d%d", &a, &l, &r, &z);
++l, ++r;
if (a == 1)
update(l, r, z);
else
printf("%d\n", query(l, r, z));
}
}
return 0;
}