HDU 2031 进制转换(10进制转R进制)

时间:2023-03-08 17:18:39

传送门:

http://acm.hdu.edu.cn/showproblem.php?pid=2031

进制转换

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 60988    Accepted Submission(s): 33224

Problem Description
输入一个十进制数N,将它转换成R进制数输出。
Input
输入数据包含多个测试实例,每个测试实例包含两个整数N(32位整数)和R(2<=R<=16, R<>10)。
Output
为每个测试实例输出转换后的数,每个输出占一行。如果R大于10,则对应的数字规则参考16进制(比如,10用A表示,等等)。
Sample Input
7 2
23 12
-4 3
Sample Output
111
1B
-11
Author
lcy
Source
Recommend
lcy   |   We have carefully selected several similar problems for you:  2032 2033 2035 2034 2039 
code:
#include <stdio.h>
#include<math.h>
#include<stdlib.h>
#include<string.h>
#include <iostream>
void f(int n,int r)
{
int m;
if(n==)
return ;
else
{
f(n/r,r);
m=n%r;
if(m<)
{
printf("%d",m);
}
else
{
printf("%c",'A'+m-);
}
}
}
int main()
{
int n,r;
while(~scanf("%d %d",&n,&r))
{
if(n==)
printf("%d",);
else if(n<)
{
printf("-");
n=-n;
}
f(n,r);
printf("\n");
}
return ;
}