PAT甲级——1033 To Fill or Not to Fill

时间:2022-09-04 18:06:25

1033 To Fill or Not to Fill

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive numbers: C​max​​ (≤ 100), the maximum capacity of the tank; D (≤30000), the distance between Hangzhou and the destination city; D​avg​​ (≤20), the average distance per unit gas that the car can run; and N (≤ 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: P​i​​, the unit gas price, and D​i​​ (≤D), the distance between this station and Hangzhou, for i=1,⋯,N. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print The maximum travel distance = X where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

Sample Input 1:

50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300

Sample Output 1:

749.17

Sample Input 2:

50 1300 12 2
7.10 0
7.00 600

Sample Output 2:

The maximum travel distance = 1200.00

待解决,思考中

这个题目我想了好几天,知道是使用贪心算法但是对于严谨性一直欠考虑。

以下是《算法笔记》AC代码:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;

const int maxn = 510;
const int INF = 1000000000;

struct station{
	double price,dis;//价格,与起点的距离
}st[maxn];

bool cmp(station a, station b)
{
	return a.dis<b.dis;//从小到大排序
}

int main()
{
	int n;
	double Cmax,D,Davg;
	scanf("%lf%lf%lf%d",&Cmax,&D,&Davg,&n);
	for(int i=0;i<n;i++)
	{
		scanf("%lf%lf",&st[i].price,&st[i].dis);
	}
	st[n].price = 0;//终点
	st[n].dis = D;//终点距离
	sort(st,st+n,cmp);//加油站从小到大排序
	if(st[0].dis!=0)//第一个加油站不为0,无法前进
	{
		printf("The maximum travel distance = 0.00\n");
	 }
	 else{
	 	int now = 0;//当前所处的加油站编号
		 double ans =0, nowTank=0, MAX = Cmax*Davg;
		 while(now<n) {
		 	//每次循环选出下一个需要到达的加油站
			 int k=-1;
			 double priceMin=INF;
			 for(int i=now+1;i<=n&&st[i].dis-st[now].dis<=MAX;i++)
			 {
			 	if(st[i].price<priceMin)
			 	{
			 		priceMin = st[i].price;
			 		k = i;
			 		if(priceMin<st[now].price)
			 		{
			 			break;
					 }
				 }
			  } 

		if(k == -1)	break;
		double need = (st[k].dis-st[now].dis)/Davg;
		if(priceMin < st[now].price)
		{
			if(nowTank<need)
			{
				ans+=(need-nowTank)*st[now].price;
				nowTank = 0;
			}
			else{
				nowTank -= need;
			}
		}
		else{
			ans+=(Cmax-nowTank)*st[now].price;
			nowTank = Cmax - need;
		}
		now= k;
		}
		if(now == n)
		{
			printf("%.2f\n",ans);
		}
		else{
			printf("The maximum travel distance = %.2f\n",st[now].dis+MAX);
		}
		}
		return 0;
}

PAT甲级——1033 To Fill or Not to Fill的更多相关文章

  1. PAT甲级1033&period; To Fill or Not to Fill

    PAT甲级1033. To Fill or Not to Fill 题意: 有了高速公路,从杭州到任何其他城市开车很容易.但由于一辆汽车的坦克容量有限,我们不得不在不时地找到加油站.不同的加油站可能会 ...

  2. PAT 甲级 1033 To Fill or Not to Fill &lpar;25 分&rpar;(贪心&comma;误以为动态规划&comma;忽视了油量问题)&ast;

    1033 To Fill or Not to Fill (25 分)   With highways available, driving a car from Hangzhou to any oth ...

  3. 【贪心】PAT 1033&period; To Fill or Not to Fill &lpar;25&rpar;

    1033. To Fill or Not to Fill (25) 时间限制 10 ms 内存限制 32000 kB 代码长度限制 16000 B 判题程序 Standard 作者 ZHANG, Gu ...

  4. PAT 1033 To Fill or Not to Fill&lbrack;dp&rsqb;

    1033 To Fill or Not to Fill(25 分) With highways available, driving a car from Hangzhou to any other ...

  5. PAT甲级题解(慢慢刷中)

    博主欢迎转载,但请给出本文链接,我尊重你,你尊重我,谢谢~http://www.cnblogs.com/chenxiwenruo/p/6102219.html特别不喜欢那些随便转载别人的原创文章又不给 ...

  6. 【转载】【PAT】PAT甲级题型分类整理

    最短路径 Emergency (25)-PAT甲级真题(Dijkstra算法) Public Bike Management (30)-PAT甲级真题(Dijkstra + DFS) Travel P ...

  7. PAT 甲级真题题解(1-62)

    准备每天刷两题PAT真题.(一句话题解) 1001 A+B Format  模拟输出,注意格式 #include <cstdio> #include <cstring> #in ...

  8. 1033 To Fill or Not to Fill

    PAT A 1033 To Fill or Not to Fill With highways available, driving a car from Hangzhou to any other ...

  9. PAT甲级目录

    树(23) 备注 1004 Counting Leaves   1020 Tree Traversals   1043 Is It a Binary Search Tree 判断BST,BST的性质 ...

随机推荐

  1. Ajax基础

    1 概要 异步JavaScript和XML(Asynchronous Javascript And XML,Ajax)就是使用js来收发来自web服务器的数据,且无需重载整个页面的技术. 注 :xml ...

  2. ADO&period;Net读取器获取数据库数据

    string str = Configuration.ConfigurationManager.AppSettings[str].ToString(); string sql = "sele ...

  3. 项目中 poi 导出 出现html特殊符号的实体 (已解决)

    导出excel 时出现 类似这样的>  符号 , 大概是存到数据库也是这样,然后jsp解析可以解析出来,但是java不认得,需要个人写出解析方法. 废话不说,贴码: /** *转换html特殊符 ...

  4. Nunit单元测试的使用

    先建立一个需要测试的项目 安装nunit 通过nuget安装Install-Package Nunit  类前加[TestFixture] 要测试的方法前加[Test] using System; u ...

  5. 华为j2ee面试题

    http://blog.csdn.net/chow__zh/article/details/7741312 java基础1.垃圾回收的优点和原理.      Java语言中一个显著的特点就是引入了垃圾 ...

  6. &period;NET开发人员必须知道的八个网站

    对于不熟悉.NET技术的朋友,需要说明一下,.NET提供了一个平台和一些相应的工具,.NET开发人员可以使用它们来在开发Windows桌面,互联网,甚至是手持移动设备上构建极富交互性的应用.很有可能你 ...

  7. BZOJ 1225&colon; &lbrack;HNOI2001&rsqb; 求正整数&lpar; dfs &plus; 高精度 &rpar;

    15 < log250000 < 16, 所以不会选超过16个质数, 然后暴力去跑dfs, 高精度计算最后答案.. ------------------------------------ ...

  8. &lbrack;转&rsqb; vue&amp&semi;webpack多页面配置

    前言 最近由于项目需求,选择使用vue框架,webpack打包直接使用的vue-cli,因为需要多页面而vue-cli只有单页面,所以就决定修改vue-cli的配置文件来满足开发需求. html-we ...

  9. Android的Launcher启动流程 &OpenCurlyDoubleQuote;Launcher部分启动流程”

    研究代码从:AndroidManifest.xml.自定义的Application.java开始. Android系统启动时,系统需要一个Home应用程序来负责将这些应用程序展示出来:也就是该应用的目 ...

  10. 深度学习 weight initialization

    转自: https://www.leiphone.com/news/201703/3qMp45aQtbxTdzmK.htmla https://blog.csdn.net/shuzfan/articl ...