POJ——1364King(差分约束SPFA判负环+前向星)

时间:2023-03-09 18:21:47
POJ——1364King(差分约束SPFA判负环+前向星)
King
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 11946   Accepted: 4365

Description

Once, in one kingdom, there was a queen and that queen was expecting a baby. The queen prayed: ``If my child was a son and if only he was a sound king.'' After nine months her child was born, and indeed, she gave birth to a nice son. 
Unfortunately, as it used to happen in royal families, the son was a little retarded. After many years of study he was able just to add integer numbers and to compare whether the result is greater or less than a given integer number. In addition, the numbers
had to be written in a sequence and he was able to sum just continuous subsequences of the sequence.

The old king was very unhappy of his son. But he was ready to make everything to enable his son to govern the kingdom after his death. With regards to his son's skills he decided that every problem the king had to decide about had to be presented in a form
of a finite sequence of integer numbers and the decision about it would be done by stating an integer constraint (i.e. an upper or lower limit) for the sum of that sequence. In this way there was at least some hope that his son would be able to make some decisions.

After the old king died, the young king began to reign. But very soon, a lot of people became very unsatisfied with his decisions and decided to dethrone him. They tried to do it by proving that his decisions were wrong.

Therefore some conspirators presented to the young king a set of problems that he had to decide about. The set of problems was in the form of subsequences Si = {aSi, aSi+1, ..., aSi+ni} of a sequence S = {a1, a2, ..., an}. The king thought a minute and then
decided, i.e. he set for the sum aSi + aSi+1 + ... + aSi+ni of each subsequence Si an integer constraint ki (i.e. aSi + aSi+1 + ... + aSi+ni < ki or aSi + aSi+1 + ... + aSi+ni > ki resp.) and declared these constraints as his decisions.

After a while he realized that some of his decisions were wrong. He could not revoke the declared constraints but trying to save himself he decided to fake the sequence that he was given. He ordered to his advisors to find such a sequence S that would satisfy
the constraints he set. Help the advisors of the king and write a program that decides whether such a sequence exists or not. 

Input

The input consists of blocks of lines. Each block except the last corresponds to one set of problems and king's decisions about them. In the first line of the block there are integers n, and m where 0 < n <= 100 is length of the sequence S and 0 < m <= 100
is the number of subsequences Si. Next m lines contain particular decisions coded in the form of quadruples si, ni, oi, ki, where oi represents operator > (coded as gt) or operator < (coded as lt) respectively. The symbols si, ni and ki have the meaning described
above. The last block consists of just one line containing 0.

Output

The output contains the lines corresponding to the blocks in the input. A line contains text successful conspiracy when such a sequence does not exist. Otherwise it contains text lamentable kingdom. There is no line in the output corresponding to the last ``null''
block of the input.

Sample Input

4 2
1 2 gt 0
2 2 lt 2
1 2
1 0 gt 0
1 0 lt 0
0

Sample Output

lamentable kingdom
successful conspiracy

题意:给你m组数据 X Y ops(gt或lt) M是否存在一个数列Ai使得对每一个不等式均有A[X]+.......+A[X+Y] ops M成立,前面的公式当然也可以化成S[X+Y]-S[X-1] ops M(写过树状数组的话这个应该更好理解)。显然这跟数列本身倒是没什么关系,题目其实就是问你这几个不等式是否存在自我矛盾,即交出来的集合是否为空。由于题目中给的是大于或小于号,而一般的差分约束通式要有等于号,题目比较友好,都是整数,那简单了,比如<M那就是≤M-1,然后建立有向图,用SPFA来判负环,用了个刚学到的前向星结构储存有向图。0MS。刚开始把X和Y看成是∑A[X]~A[Y]了,WA几发,还有每一次SPFA完后清空下d数组和viscnt数组。

代码:

#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<sstream>
#include<cstring>
#include<cstdio>
#include<string>
#include<deque>
#include<stack>
#include<cmath>
#include<queue>
#include<set>
#include<map>
#define INF 0x3f3f3f3f
#define MM(x) memset(x,0,sizeof(x))
using namespace std;
typedef long long LL;
const int N=110;
const int MAX=10;
struct info
{
int to;
int dx;
int pre;
}E[N];
int n,m;
int cnt,head[N];
int d[N];
int viscnt[N];
int flag;
int S[N],C;
void init()
{
cnt=0;
memset(head,-1,sizeof(head));
memset(d,INF,sizeof(d));
MM(viscnt);
flag=1;
MM(S);
C=0;
}
void add(int s,int t,int dx)
{
E[cnt].to=t;
E[cnt].dx=dx;
E[cnt].pre=head[s];
head[s]=cnt++;
} void spfa(int s)
{
d[s]=0;
priority_queue<pair<int,int> >Q;
Q.push(pair<int,int>(-d[s],s));
while (!Q.empty())
{
int now=Q.top().second;
if(++viscnt[now]>n)
{
flag=0;
break;
}
Q.pop();
for (int i=head[now]; i!=-1; i=E[i].pre)
{
int v=E[i].to;
if(d[v]>d[now]+E[i].dx)
{
d[v]=d[now]+E[i].dx;
Q.push(pair<int,int>(-d[v],v));
}
}
}
}
int main(void)
{
int i,j,x,y,z;
char ops[6];
while (~scanf("%d",&n)&&n)
{
scanf("%d",&m);
init();
for (i=0; i<m; i++)
{
scanf("%d %d %s %d",&x,&y,ops,&z);
y+=x;
if(ops[0]=='g')
{
add(y,x-1,-z-1);
S[C++]=y;
}
else
{
add(x-1,y,z-1);
S[C++]=x-1;
}
}
for (i=0; i<C; i++)
{
spfa(S[i]);
if(!flag)
{
puts("successful conspiracy");
break;
}
memset(d,INF,sizeof(d));
MM(viscnt);
}
if(flag)
puts("lamentable kingdom");
}
return 0;
}