Poj OpenJudge 百练 1860 Currency Exchang

时间:2022-09-04 15:14:03

1.Link:

http://poj.org/problem?id=1860

http://bailian.openjudge.cn/practice/1860

2.Content:

Currency Exchange
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 20706   Accepted: 7428

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 104

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

Source

Northeastern Europe 2001, Northern Subregion

3.Method:

此题重在知道使用Bellman-Ford算法

算法原理参考:

(1)算法艺术与信息学竞赛 307页

(2)http://baike.baidu.com/view/1481053.htm

思路参考了:

http://blog.csdn.net/lyy289065406/article/details/6645778

http://www.cppblog.com/MemoryGarden/archive/2008/09/04/60912.html (这个思路有问题,一开始我也是这种思路)

4.Code:

 #include <iostream>
 #include <cstring>

 using namespace std;

 struct Exchange
 {
     int a;
     int b;
     double r;
     double c;
 };

 int main()
 {
     //freopen("D://input.txt","r",stdin);

     int i,j;

     int n,m,s;
     double v;

     cin >> n >> m >> s >> v;

     Exchange *arr_ec = ];

     int a,b;
     double rab,cab,rba,cba;
     ; i < m; ++i)
     {
         cin >> a >> b >> rab >> cab >> rba >> cba;

         arr_ec[i * ].a = a - ;
         arr_ec[i * ].b = b - ;
         arr_ec[i * ].r = rab;
         arr_ec[i * ].c = cab;

         arr_ec[i *  + ].a = b - ;
         arr_ec[i *  + ].b = a - ;
         arr_ec[i *  + ].r = rba;
         arr_ec[i *  + ].c = cba;
     }

     //for(i = 0; i < m * 2; ++i) cout << arr_ec[i].a << " " << arr_ec[i].b << " " << arr_ec[i].r << " " << arr_ec[i].c << endl;

     double *d = new double[n];
     memset(d, , sizeof(double) * n);
     d[s - ] = v;

     //for(i = 0; i < n; ++i) cout << d[i] << " ";

     //Bellman-Ford
     int flag;
     ; i <= n - ; ++i)
     {
         flag = ;
         ; j <  * m; ++j)
         {
             if(d[arr_ec[j].b] < (d[arr_ec[j].a] - arr_ec[j].c) * arr_ec[j].r)
             {
                 d[arr_ec[j].b] = (d[arr_ec[j].a] - arr_ec[j].c) * arr_ec[j].r;
                 flag = ;
             }
         }
         if(!flag) break;
         //for(j = 0; j < n; ++j) cout << d[j] << " ";
         //cout << endl;
     }

     ; i <  * m; ++i)
     {
         if(d[arr_ec[i].b] < (d[arr_ec[i].a] - arr_ec[i].c) * arr_ec[i].r) break;
     }

      * m) cout << "YES" << endl;
     else cout << "NO" << endl;

     delete [] d;
     delete [] arr_ec;

     ;
 }

5.Reference:

Poj OpenJudge 百练 1860 Currency Exchang的更多相关文章

  1. Poj OpenJudge 百练 1062 昂贵的聘礼

    1.Link: http://poj.org/problem?id=1062 http://bailian.openjudge.cn/practice/1062/ 2.Content: 昂贵的聘礼 T ...

  2. Poj OpenJudge 百练 2602 Superlong sums

    1.Link: http://poj.org/problem?id=2602 http://bailian.openjudge.cn/practice/2602/ 2.Content: Superlo ...

  3. Poj OpenJudge 百练 2389 Bull Math

    1.Link: http://poj.org/problem?id=2389 http://bailian.openjudge.cn/practice/2389/ 2.Content: Bull Ma ...

  4. Poj OpenJudge 百练 1573 Robot Motion

    1.Link: http://poj.org/problem?id=1573 http://bailian.openjudge.cn/practice/1573/ 2.Content: Robot M ...

  5. Poj OpenJudge 百练 2632 Crashing Robots

    1.Link: http://poj.org/problem?id=2632 http://bailian.openjudge.cn/practice/2632/ 2.Content: Crashin ...

  6. Poj OpenJudge 百练 Bailian 1008 Maya Calendar

    1.Link: http://poj.org/problem?id=1008 http://bailian.openjudge.cn/practice/1008/ 2.content: Maya Ca ...

  7. Openjudge 百练第4109题

    在OpenJudge看到一个题目(#4109),题目描述如下: 小明和小红去参加party.会场中总共有n个人,这些人中有的是朋友关系,有的则相互不认识.朋友关系是相互的,即如果A是B的朋友,那么B也 ...

  8. &lbrack;OpenJudge&rsqb; 百练2754 八皇后

    八皇后 Description 会下国际象棋的人都很清楚:皇后可以在横.竖.斜线上不限步数地吃掉其他棋子.如何将8个皇后放在棋盘上(有8 * 8个方格),使它们谁也不能被吃掉!这就是著名的八皇后问题. ...

  9. POJ 1860 Currency Exchange 最短路&plus;负环

    原题链接:http://poj.org/problem?id=1860 Currency Exchange Time Limit: 1000MS   Memory Limit: 30000K Tota ...

随机推荐

  1. DOS下windows系统查看wifi密码

    DOS下windows系统查看wifi密码 首先,按win+R键,win键如下 弹出框中输入cmd 在弹出界面输入 netsh wlan show profiles 你可以看到你链接过的所有wifi名 ...

  2. Optimistic Concurrency VS&period; Pessimistic Concurrency Control

    原创地址:http://www.cnblogs.com/jfzhu/p/4009918.html 转载请注明出处   (一)为什么需要并发控制机制 并发控制机制是为了防止多个用户同时更改同一条数据,也 ...

  3. 使用Github Pages创建自己的网站

    这是一篇使用Github Pages创建自己网站的教程,操作很简单,相信,亲们肯定一学就会,但是大家也要有一定的github基础呀,所以小编给大家附上一个链接(http://www.cnblogs.c ...

  4. 234&period; Palindrome Linked List

    题目: Given a singly linked list, determine if it is a palindrome. Follow up:Could you do it in O(n) t ...

  5. C&num;中的try catch finally

    try中的程序块是有可能发生错误的程序块,catch中的程序块是当发生错误的时候才会执行的代码块,finally中的程序块是无论是否发生错误都会执行的代码块. 示例程序: ? 1 2 3 4 5 6 ...

  6. Codevs 1690 开关灯 USACO

    1690 开关灯 USACO 时间限制: 1 s 空间限制: 128000 KB 题目等级 : 钻石 Diamond 传送门 题目描述 Description YYX家门前的街上有N(2<=N& ...

  7. BZOJ3412&colon; &lbrack;Usaco2009 Dec&rsqb;Music Notes乐谱

    3412: [Usaco2009 Dec]Music Notes乐谱 Time Limit: 3 Sec  Memory Limit: 128 MBSubmit: 35  Solved: 30[Sub ...

  8. 从零开始学习Vue&lpar;三&rpar;

    我们从一个例子来学习组件,vuejs2.0实战:仿豆瓣app项目,创建自定义组件tabbar 这个例子用到其他组件,对于初学者来说,一下子要了解那么多组件的使用,会变得一头雾水.所以我把这个例子改写了 ...

  9. Spring的事件机制详解

    同步事件和异步事件 同步事件:在一个线程里,按顺序执行业务,做完一件事再去做下一件事. 异步事件:在一个线程里,做一个事的同事,可以另起一个新的线程执行另一件事,这样两件事可以同时执行. 用一个例子来 ...

  10. SignalR 设计理念&lpar;二&rpar;

    SignalR 设计理念(二) 实现客户端和服务器端的实时通讯. 前言: 客户端方法忽略大小写,主要原因基于是URL对大小写不敏感的问题,开发者之间为了更好的协同开发,定下的开发者协议. 问题阐述 客 ...