九度 Online Judge 算法 刷题 题目1098:字母统计

时间:2023-02-12 12:39:59

题目1098:字母统计

题目描述:
输入一行字符串,计算其中A-Z大写字母出现的次数
输入:
案例可能有多组,每个案例输入为一行字符串。
输出:
对每个案例按A-Z的顺序输出其中大写字母出现的次数。
样例输入:
DFJEIWFNQLEF0395823048+_+JDLSFJDLSJFKK
样例输出:
A:0
B:0
C:0
D:3
E:2
F:5
G:0
H:0
I:1
J:4
K:2
L:3
M:0
N:1
O:0
P:0
Q:1
R:0
S:2
T:0
U:0
V:0
W:1
X:0
Y:0
Z:0
来源:
2009年上海交通大学计算机研究生机试真题

code

c语言实现

#include<stdio.h>
 
int main() {
    char a[1500];
    int i,j;
    int b[26]={0};
    while(scanf("%s",a) != EOF) {
        for (j=0;j<26;j++)
            b[j]=0;
        for (i=0;i<strlen(a);i++)
            for (j=0;j<26;j++)
                if (a[i] == 'A'+j)
                    b[j]++;
        for (j=0;j<26;j++)
            printf("%c:%d\n",'A'+j,b[j]);
 
         
    }
 
    return 0;
}
/**************************************************************     Problem: 1098     User: langzimaizan     Language: C     Result: Accepted     Time:0 ms     Memory:912 kb ****************************************************************/