HDU 1724 Ellipse

时间:2024-01-16 22:52:08
Problem Description
Math is important!! Many students failed in 2+2’s mathematical test, so let's AC this problem to mourn for our lost youth..
Look this sample picture:

HDU 1724 Ellipse

A
ellipses in the plane and center in point O. the L,R lines will be
vertical through the X-axis. The problem is calculating the blue
intersection area. But calculating the intersection area is dull, so I
have turn to you, a talent of programmer. Your task is tell me the
result of calculations.(defined PI=3.14159265 , The area of an ellipse
A=PI*a*b )

Input
Input
may contain multiple test cases. The first line is a positive integer
N, denoting the number of test cases below. One case One line. The line
will consist of a pair of integers a and b, denoting the ellipse
equation HDU 1724 Ellipse, A pair of integers l and r, mean the L is (l, 0) and R is (r, 0). (-a <= l <= r <= a).
Output
For
each case, output one line containing a float, the area of the
intersection, accurate to three decimals after the decimal point.
Sample Input
2
2 1 -2 2
2 1 0 2
Sample Output
6.283
3.142
自适应辛普森的模板
 #include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
double pi=acos(-1.0);
double a,b;
double F(double x)
{
return b*sqrt(-x*x/(a*a));
}
double simpson(double l,double r)
{
return (r-l)*(F(l)+*F((l+r)/2.0)+F(r))/6.0;
}
double asr(double l,double r,double eps,double A)
{
double mid=(l+r)/2.0;
double LS=simpson(l,mid),RS=simpson(mid,r);
if (fabs(LS+RS-A)<=*eps) return LS+RS+(LS+RS-A)/15.0;
return asr(l,mid,eps/,LS)+asr(mid,r,eps/,RS);
}
int main()
{double eps=1e-;
int T;
double l,r;
cin>>T;
while (T--)
{
scanf("%lf%lf%lf%lf",&a,&b,&l,&r);
printf("%.3lf\n",asr(l,r,eps,simpson(l,r))*2.0);
}
}