ACM HDU 1081 To The Max

时间:2023-12-11 17:50:32
ACM HDU 1081 To The Max

To The Max

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 10839    Accepted Submission(s): 5191

Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle
is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.



As an example, the maximal sub-rectangle of the array:



0 -2 -7 0

9 2 -6 2

-4 1 -4 1

-1 8 0 -2



is in the lower left corner:



9 2

-4 1

-1 8



and has a sum of 15.
Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is
followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may
be as large as 100. The numbers in the array will be in the range [-127,127].
Output
Output the sum of the maximal sub-rectangle.
Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2
Sample Output
15
题目大意:给一个N*N的矩阵求解最大的子矩阵和
解法:压缩数组+暴力(水过)
ACM HDU 1081 To The Max
源代码:
<span style="font-size:18px;">#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string>
#include<string.h>
#include<math.h>
#include<map>
#include<vector>
#include<algorithm>
#include<queue>
using namespace std;
#define MAX 0x3f3f3f3f
#define MIN -0x3f3f3f3f
#define PI 3.14159265358979323
#define N 105
int n;
int ans[N][N];
int value(int x, int y)
{
int sum;
int i, j;
sum = 0;
for (i = 1; i <= n; i++)
{
for (j = 1; j <= n; j++)
{
if (i >= x&&j >= y)
sum = max(sum, ans[i][j] + ans[i - x][j - y] - ans[i - x][j] - ans[i][j - y]);
if (i >= y&&j >= x)
sum = max(sum, ans[i][j] + ans[i - y][j - x] - ans[i - y][j] - ans[i][j - x]);
}
}
return sum;
}
int main()
{
int i, j;
int result;
int num;
int temp;
while (scanf("%d", &n) != EOF)
{
memset(ans, 0, sizeof(ans));
for (i = 1; i <= n; i++)
{
for (j = 1; j <= n; j++)
{
scanf("%d", &num);
ans[i][j] = ans[i - 1][j] + ans[i][j - 1] - ans[i - 1][j - 1] + num;
}
}
result = 0;
for (i = 1; i <= n; i++)
{
for (j = i; j <= n; j++)
{
temp = value(i, j);
if (temp > result)
result = temp;
}
}
printf("%d\n", result);
}
return 0;
}</span>