HDOJ 1528 Card Game Cheater

时间:2023-12-06 16:14:32

版权声明:来自: 码代码的猿猿的AC之路 http://blog.csdn.net/ck_boss https://blog.csdn.net/u012797220/article/details/35236457

简单二分图匹配....

Card Game Cheater

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1073    Accepted Submission(s): 565

Problem Description
Adam and Eve play a card game using a regular deck of 52 cards. The rules are simple. The players sit on opposite sides of a table, facing each other. Each player gets k cards from the deck and, after looking at them, places the cards face down in a row on
the table. Adam’s cards are numbered from 1 to k from his left, and Eve’s cards are numbered 1 to k from her right (so Eve’s i:th card is opposite Adam’s i:th card). The cards are turned face up, and points are awarded as follows (for each i ∈ {1, . . . ,
k}):

If Adam’s i:th card beats Eve’s i:th card, then Adam gets one point.

If Eve’s i:th card beats Adam’s i:th card, then Eve gets one point.

A card with higher value always beats a card with a lower value: a three beats a two, a four beats a three and a two, etc. An ace beats every card except (possibly) another ace.

If the two i:th cards have the same value, then the suit determines who wins: hearts beats all other suits, spades beats all suits except hearts, diamond beats only clubs, and clubs does not beat any suit. 

For example, the ten of spades beats the ten of diamonds but not the Jack of clubs. 

This ought to be a game of chance, but lately Eve is winning most of the time, and the reason is that she has started to use marked cards. In other words, she knows which cards Adam has on the table before he turns them face up. Using this information she orders
her own cards so that she gets as many points as possible.

Your task is to, given Adam’s and Eve’s cards, determine how many points Eve will get if she plays optimally. 

Input
There will be several test cases. The first line of input will contain a single positive integer N giving the number of test cases. After that line follow the test cases.

Each test case starts with a line with a single positive integer k <= 26 which is the number of cards each player gets. The next line describes the k cards Adam has placed on the table, left to right. The next line describes the k cards Eve has (but she has
not yet placed them on the table). A card is described by two characters, the first one being its value (2, 3, 4, 5, 6, 7, 8 ,9, T, J, Q, K, or A), and the second one being its suit (C, D, S, or H). Cards are separated by white spaces. So if Adam’s cards are
the ten of clubs, the two of hearts, and the Jack of diamonds, that could be described by the line

TC 2H JD

Output
For each test case output a single line with the number of points Eve gets if she picks the optimal way to arrange her cards on the table.

Sample Input

3
1
JD
JH
2
5D TC
4C 5H
3
2H 3H 4H
2D 3D 4D

Sample Output

1
1
2

Source
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm> using namespace std; int n;
char card[2][30][2];
int mp[30][30]; const char value[13]={'2','3','4','5','6','7','8','9','T','J','Q','K','A'};
const char sign[4]={'C','D','S','H'}; bool bigger(char c1[2],char c2[2])
{
int v1,v2;
int s1,s2;
for(int i=0;i<13;i++)
{
if(c1[0]==value[i]) v1=i;
if(c2[0]==value[i]) v2=i;
} if(v1>v2)
{
return true;
}
else if(v1==v2)
{
for(int i=0;i<4;i++)
{
if(c1[1]==sign[i]) s1=i;
if(c2[1]==sign[i]) s2=i;
}
if(s1>s2) return true;
else return false;
}
else return false;
} int linker[30];
bool used[30]; bool dfs(int u)
{
for(int i=1;i<=n;i++)
{
if(mp[u][i])
{
if(used[i]) continue;
used[i]=true;
if(linker[i]==-1||dfs(linker[i]))
{
linker[i]=u;
return true;
}
}
}
return false;
} int hungary()
{
int ret=0;
memset(linker,-1,sizeof(linker));
for(int i=1;i<=n;i++)
{
memset(used,false,sizeof(used));
if(dfs(i)) ret++;
}
return ret;
} int main()
{
int T_T;
scanf("%d",&T_T);
while(T_T--)
{
scanf("%d",&n);
memset(mp,0,sizeof(mp));
for(int i=1;i<=n;i++) scanf("%s",card[1][i]);
for(int i=1;i<=n;i++) scanf("%s",card[0][i]);
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
if(bigger(card[0][i],card[1][j]))
{
mp[i][j]=true;
}
}
}
printf("%d\n",hungary());
}
return 0;
}