POJ 1274 The Perfect Stall、HDU 2063 过山车(最大流做二分匹配)

时间:2022-09-30 17:42:48
The Perfect Stall
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 24081   Accepted: 10695

Description

Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall. 
Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible.

Input

The input includes several cases. For each case, the first line contains two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn. Each of the following N lines corresponds to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1..M), and no stall will be listed twice for a given cow.

Output

For each case, output a single line with a single integer, the maximum number of milk-producing stall assignments that can be made.

Sample Input

5 5
2 2 5
3 2 3 4
2 1 5
3 1 2 5
1 2

Sample Output

4

题目链接:POJ 1274

今天用做了这两道题才知道用最大流解决二分匹配的正确姿势 :首先不要一开始就往S、T这两个点里加边,因为很可能一个点会多次与S相连,那这样这个点总的流量就不是1了。

假设二分图的左半部分是集合$L_i$、右半部分是集合$R_i$,那么首先从$L_i$到$R_i$连一条流量为INF的边,然后将$L_i$与$R_i$记录到各自的集合里,然后各自去重,再从S到去重后的左集合中各点连一条容量为1的边,从右集合$R_i$中各点连向T也是一条容量为1的边,然后再跑最大流,代码是POJ的题目代码,HDU的把左边也去重就好了。

至于为什么可以这么做,显然对于左半部任意的点,从源点拿到手的流量只有1,即只能送给右半部的一个点,而且右半部流进汇点的容量也只有1,两边分别这样避免了一个人去匹配多个人或者一个人被多个人匹配的情况。想一想大概是这么个情况,但是中间边的容量为什么是INF,这两题只设1也是可以过的,不是很理解,感觉中间的流量在简单的二分图匹配里设为多少似乎没什么影响,只要大于1就行

代码:

#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <cstdlib>
#include <sstream>
#include <cstring>
#include <bitset>
#include <string>
#include <deque>
#include <stack>
#include <cmath>
#include <queue>
#include <set>
#include <map>
using namespace std;
#define INF 0x3f3f3f3f
#define CLR(arr,val) memset(arr,val,sizeof(arr))
#define LC(x) (x<<1)
#define RC(x) ((x<<1)+1)
#define MID(x,y) ((x+y)>>1)
typedef pair<int,int> pii;
typedef long long LL;
const double PI=acos(-1.0);
const int N=210<<1;
const int M=N*N*2;
struct edge
{
int to,nxt;
int cap;
};
edge E[M];
int head[N],tot;
int d[N];
vector<int>stall; void init()
{
CLR(head,-1);
tot=0;
stall.clear();
}
void add(int s,int t,int c)
{
E[tot].to=t;
E[tot].cap=c;
E[tot].nxt=head[s];
head[s]=tot++; E[tot].to=s;
E[tot].cap=0;
E[tot].nxt=head[t];
head[t]=tot++;
}
int bfs(int s,int t)
{
CLR(d,INF);
d[s]=0;
queue<int>Q;
Q.push(s);
while (!Q.empty())
{
int now=Q.front();
Q.pop();
for (int i=head[now]; ~i; i=E[i].nxt)
{
int v=E[i].to;
if(d[v]==INF&&E[i].cap)
{
d[v]=d[now]+1;
if(v==t)
return 1;
Q.push(v);
}
}
}
return d[t]!=INF;
}
int dfs(int s,int t,int f)
{
if(s==t||!f)
return f;
int ret=0;
for (int i=head[s]; ~i; i=E[i].nxt)
{
int v=E[i].to;
if(d[v]==d[s]+1&&E[i].cap>0)
{
int d=dfs(v,t,min(f,E[i].cap));
if(d>0)
{
E[i].cap-=d;
E[i^1].cap+=d;
f-=d;
ret+=d;
if(!f)
break;
}
}
}
if(!ret)
d[s]=-1;
return ret;
}
int dinic(int s,int t)
{
int ret=0;
while (bfs(s,t))
ret+=dfs(s,t,INF);
return ret;
}
int main(void)
{
int n,m,b,k,i;
while (~scanf("%d%d",&n,&m))
{
init();
int S=0,T=n+m+1;
for (i=1; i<=n; ++i)
{
scanf("%d",&k);
add(S,i,1);
while (k--)
{
scanf("%d",&b);
add(i,n+b,INF);
stall.push_back(b);
}
}
sort(stall.begin(),stall.end());
stall.erase(unique(stall.begin(),stall.end()),stall.end());
int R=stall.size();
for (i=0; i<R; ++i)
add(n+stall[i],T,1);
printf("%d\n",dinic(S,T));
}
return 0;
}

POJ 1274 The Perfect Stall、HDU 2063 过山车(最大流做二分匹配)的更多相关文章

  1. HDU 2063 过山车 第一道最大二分匹配

    http://acm.hdu.edu.cn/showproblem.php?pid=2063 题目大意: m个女生和n个男生一起做过山车,每一排必须一男一女,而每个女孩愿意和一些男生坐一起,, 你要找 ...

  2. Luogu 1894 &lbrack;USACO4&period;2&rsqb;完美的牛栏The Perfect Stall &sol; POJ 1274 The Perfect Stall(二分图最大匹配)

    Luogu 1894 [USACO4.2]完美的牛栏The Perfect Stall / POJ 1274 The Perfect Stall(二分图最大匹配) Description 农夫约翰上个 ...

  3. poj——1274 The Perfect Stall

    poj——1274   The Perfect Stall Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 25709   A ...

  4. POJ 1274 The Perfect Stall &vert;&vert; POJ 1469 COURSES(zoj 1140)二分图匹配

    两题二分图匹配的题: 1.一个农民有n头牛和m个畜栏,对于每个畜栏,每头牛有不同喜好,有的想去,有的不想,对于给定的喜好表,你需要求出最大可以满足多少头牛的需求. 2.给你学生数和课程数,以及学生上的 ...

  5. hdu 2063 过山车&lpar;匈牙利算法模板)

    http://acm.hdu.edu.cn/showproblem.php?pid=2063 过山车 Time Limit: 1000/1000 MS (Java/Others)    Memory ...

  6. hdu 2063 过山车 二分匹配(匈牙利算法)

    简单题hdu2063 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2063 过山车 Time Limit: 1000/1000 MS (Java/Ot ...

  7. hdu 2063 过山车(模板)

    题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2063 过山车 Time Limit: 1000/1000 MS (Java/Others)    Me ...

  8. &lbrack;题解&rsqb;poj 1274 The Perfect Stall&lpar;网络流&rpar;

    二分匹配传送门[here] 原题传送门[here] 题意大概说一下,就是有N头牛和M个牛棚,每头牛愿意住在一些牛棚,求最大能够满足多少头牛的要求. 很明显就是一道裸裸的二分图最大匹配,但是为了练练网络 ...

  9. poj 1274 The Perfect Stall【匈牙利算法模板题】

    The Perfect Stall Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 20874   Accepted: 942 ...

随机推荐

  1. Linux-深入理解Socket异常

    在各种网络异常情况的背后,TCP是怎么处理的?又是怎样把处理结果反馈给上层应用的?本文就来讨论这个问题.分为两个场景来讨论 建立连接时的异常情况 1 正常情况下 经过三次握手,客户端连接成功,服务端有 ...

  2. Memento

    #include <iostream> #include <string> using namespace std; class Memento { public: Memen ...

  3. 如何开启PDO&comma;PDO&lowbar;MYSQL扩展

    开启这个功能的具体方法就是设置php.ini文件,步骤如下: 1.查看public_html目录下没有php.ini文件,如果有的, 打开文件查找 extension=php_pdo_mysql.dl ...

  4. cf493D Vasya and Chess

    D. Vasya and Chess time limit per test 2 seconds memory limit per test 256 megabytes input standard ...

  5. Struts学习之模型驱动

    * 要从页面中获取表单元素的值,需要在动作类中声明与页面元素同名的属性.导致动作类中既有javabean又有业务方法.    * 将javabean和业务方法进行分离:        * 将重新创建一 ...

  6. linux 使用技巧 screen 管理你的远程桌面的会话创建和使用

    下面介绍  screen 使用的技巧教你管理远程会话 你是不是经常需要 SSH 或者 telent 远程登录到 Linux 服务器?你是不是经常为一些长时间运行的任务而头疼,比如系统备份. ftp 传 ...

  7. luogu 1966 火柴排队 离散化&plus;逆序对

    题意:找到最小改变对数使a数组的第i大和b数组的第i大相等 则先将a,b,数组编号再排序,则数组显示的就是排名第i的数的编号 再关键一步:c[a[i].id]=b[i].id 实质上就是新建一个数组, ...

  8. express安装中出现无此命令

    原来,最新express4.0版本中将命令工具分家出来了(项目地址:https://github.com/expressjs/generator),所以我们还需要安装一个命令工具,命令如下: 安装ex ...

  9. nodejs&amp&semi;mongo&amp&semi;angularjs

    http://www.ibm.com/developerworks/cn/web/wa-nodejs-polling-app/

  10. Oracle SYS用户无法设置session级别的read only

    官方文档参考:SYSDBA is used internally in the Oracle database and has specialized functions. Its behavior ...